hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jeff saremi <jeffsar...@hotmail.com>
Subject Re: hbase-default.xml seems to be for an older version of HBase
Date Sun, 05 Mar 2017 23:45:25 GMT
This is what happens when you run it in MIngw:


Build sequence for target(s) `main' is [main]
Complete build sequence is [main, ]

main:
Setting project property: generated.sources -> D:\repos\hbase\hbase-common\target\generated-sources
     [exec] Current OS is Windows 10
     [exec] Executing 'bash' with arguments:
     [exec] 'D:\repos\hbase\hbase-common/src/saveVersion.sh'
     [exec] '1.2.2'
     [exec] 'D:\repos\hbase\hbase-common\target\generated-sources/java'
     [exec]
     [exec] The ' characters around the executable and arguments are
     [exec] not part of the command.
Execute:Java13CommandLauncher: Executing 'bash' with arguments:
'D:\repos\hbase\hbase-common/src/saveVersion.sh'
'1.2.2'
'D:\repos\hbase\hbase-common\target\generated-sources/java'

The ' characters around the executable and arguments are
not part of the command.
     [exec] Error: 0x80070057
     [exec]
     [exec] Result: -1
[INFO] Executed tasks
[INFO]


Note how the shell script now has D:\ path versus /d/ path

this corresponds to:

${basedir}/src/saveVersion.sh

________________________________
From: Ted Yu <yuzhihong@gmail.com>
Sent: Friday, March 3, 2017 8:21:41 PM
To: dev@hbase.apache.org
Subject: Re: hbase-default.xml seems to be for an older version of HBase

w.r.t. mixed path separators, were you referring to:

mkdir -p "$outputDirectory/org/apache/hadoop/hbase"
cat >"$outputDirectory/org/apache/hadoop/hbase/Version.java" <<EOF

Cheers

On Fri, Mar 3, 2017 at 7:44 PM, jeff saremi <jeffsaremi@hotmail.com> wrote:

> The issue is the mixed path separators being passed to the script
> saveVersion.sh
>
> I recompiled on Ubuntu and everything is fine now.
>
> So the take away is that the exec step can fail however maven reports
> build successful.
>
> thanks
>
> ________________________________
> From: jeff saremi <jeffsaremi@hotmail.com>
> Sent: Friday, March 3, 2017 6:47:05 PM
> To: dev@hbase.apache.org
> Subject: hbase-default.xml seems to be for an older version of HBase
>
>
> I get this baffling error message after doing a compilation of Hbase
> rel/1.2.2 (on Windows/Mingw) and running it on a windows server.
>
> Looking at the source, hbase-default.xml is in the hbase-common project
> and I verified it to be included in the runtime jar file.
>
> I cannot say anything about the contents of this file since it seems to be
> filled with references and place holders. I am attaching it as extracted
> from the hbase-common-1.2.2jar.
>
> Thanks
>
>
> Exception in thread "main" java.lang.RuntimeException: hbase-default.xml
> file seems to be for an older version of HBase (1.2.2), this version is
> Unknown
>         at org.apache.hadoop.hbase.HBaseConfiguration.
> checkDefaultsVersion(HBaseConfiguration.java:71)
>         at org.apache.hadoop.hbase.HBaseConfiguration.addHbaseResources(
> HBaseConfiguration.java:81)
>         at org.apache.hadoop.hbase.HBaseConfiguration.create(
> HBaseConfiguration.java:96)
>         at org.apache.hadoop.hbase.regionserver.HRegionServer.
> main(HRegionServer.java:2660)
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message