hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Jiang <syuanjiang...@gmail.com>
Subject Re: set up hbase project in eclipse after protobuf3 change
Date Mon, 10 Oct 2016 20:21:47 GMT
My bad.  I just simply imported the module and had this problem.  I should
do 'mvn eclipse:eclipse' first. After doing this, the problem went away.

Thanks
Stephen

On Mon, Oct 10, 2016 at 12:36 PM, Ted Yu <yuzhihong@gmail.com> wrote:

> Stephen:
> I tried some file (ForeignExceptionUtil) where I don't see the red
> underline.
>
> I am using Neon (4.6).
> Which version of Eclipse are you using ?
>
> Cheers
>
> On Mon, Oct 10, 2016 at 11:15 AM, Stephen Jiang <syuanjiangdev@gmail.com>
> wrote:
>
> > More information:
> > For example, For the generated files under  hbase-protocol-shaded, I have
> > this error in the eclipse - *The declared package
> > "org.apache.hadoop.hbase.shaded.protobuf.generated" does not match the
> > expected package
> > "src.main.java.org.apache.hadoop.hbase.shaded.protobuf.generated"*
> >
> > On Mon, Oct 10, 2016 at 11:09 AM, Stephen Jiang <syuanjiangdev@gmail.com
> >
> > wrote:
> >
> > > After the protobuf3 change, I update the eclipse by adding the
> > > hbase-protocol-shaded module in the project by "import existing maven
> > > project".  However, eclipse did not recognize this; it shows red
> > underlines
> > > for the org.apache.hadoop.hbase.shaded.protobuf.generated.*
> > > (interestingly, I can run unit tests without problem in eclipse).
> > >
> > > I just wonder anyone is using eclipse and see the same problem (and how
> > to
> > > resolve this).
> > >
> > > Thanks
> > > Stephen
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message