hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yu Li <car...@gmail.com>
Subject Re: [DISCUSS] Drop legacy hadoop support at the 2.0 release
Date Thu, 20 Oct 2016 11:17:55 GMT
+1, we are running 2.6.x online and it's also stable.

Best Regards,
Yu

On 20 October 2016 at 13:30, Jerry He <jerryjch@gmail.com> wrote:

> Concur here.  Our distribution has on 2.7.x lines for a while.
>
> Jerry
>
> On Oct 19, 2016 6:26 PM, "张铎" <palomino219@gmail.com> wrote:
>
> > OK, seems no objection. I will file a issue to modify the hadoop version
> > support matrix.
> >
> > And I think we also need to change the hadoopcheck versions for our
> > precommit check?
> >
> > Thanks all.
> >
> > 2016-10-20 1:14 GMT+08:00 Andrew Purtell <apurtell@apache.org>:
> >
> > > FWIW, we are running 2.7.x in production and it's stable.
> > >
> > >
> > > On Tue, Oct 18, 2016 at 10:18 PM, Sean Busbey <busbey@apache.org>
> wrote:
> > >
> > > > we had not decided yet AFAIK. a big concern was the lack of
> > > > maintenance releases on more recent Hadoop versions and the
> perception
> > > > that 2.4 and 2.5 were the last big stable release lines.
> > > >
> > > > 2.6 and 2.7 have both gotten a few maintenance releases now, so maybe
> > > > this isn't a concern any more?
> > > >
> > > > On Tue, Oct 18, 2016 at 7:00 PM, Enis Söztutar <enis.soz@gmail.com>
> > > wrote:
> > > > > I thought we already decided to do that, no?
> > > > >
> > > > > Enis
> > > > >
> > > > > On Tue, Oct 18, 2016 at 6:56 PM, Ted Yu <yuzhihong@gmail.com>
> wrote:
> > > > >
> > > > >> Looking at http://hadoop.apache.org/releases.html , 2.5.x hasn't
> > got
> > > > new
> > > > >> release for almost two years.
> > > > >>
> > > > >> Seems fine to drop support for 2.4 and 2.5
> > > > >>
> > > > >> On Tue, Oct 18, 2016 at 6:42 PM, Duo Zhang <zhangduo@apache.org>
> > > wrote:
> > > > >>
> > > > >> > This is the current hadoop version support matrix
> > > > >> >
> > > > >> > https://hbase.apache.org/book.html#hadoop
> > > > >> >
> > > > >> > 2016-10-19 9:40 GMT+08:00 Duo Zhang <zhangduo@apache.org>:
> > > > >> >
> > > > >> > > To be specific, hadoop-2.4.x and hadoop-2.5.x.
> > > > >> > >
> > > > >> > > The latest releases for these two lines are about two
years
> ago,
> > > so
> > > > I
> > > > >> > > think it is the time to drop the support of them when
2.0 out.
> > > Then
> > > > we
> > > > >> > > could drop some code in our hadoop-compat module as
we may
> need
> > to
> > > > add
> > > > >> > some
> > > > >> > > code for the incoming hadoop-3.0...
> > > > >> > >
> > > > >> > > Thanks.
> > > > >> > >
> > > > >> >
> > > > >>
> > > >
> > >
> > >
> > >
> > > --
> > > Best regards,
> > >
> > >    - Andy
> > >
> > > Problems worthy of attack prove their worth by hitting back. - Piet
> Hein
> > > (via Tom White)
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message