hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-11441) [hadoopqa] jenkinsEnv paths are stale/wrong; JAVA_HOME in particular
Date Fri, 09 Sep 2016 20:23:20 GMT

     [ https://issues.apache.org/jira/browse/HBASE-11441?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sean Busbey resolved HBASE-11441.
---------------------------------
    Resolution: Cannot Reproduce

closing as obviated by our current JDK woes and the docker work in HBASE-16591

> [hadoopqa] jenkinsEnv paths are stale/wrong; JAVA_HOME in particular
> --------------------------------------------------------------------
>
>                 Key: HBASE-11441
>                 URL: https://issues.apache.org/jira/browse/HBASE-11441
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>            Reporter: stack
>            Priority: Minor
>
> jenkinsEnv paths are off.
> We moved to jdk1.7 for master branch.  Though we'd set hadoopqa to run with java 1.7,
the jenkinsEnv overrides what jenkins sets for JAVA_HOME so we've been running 1.6 java over
this last couple of months rather than 1.7.
> Trying to work around jenkinsEnv settings reveals that there is no 1.7 at the location
jenkins goes to find it at ("Latest JDK 7" option):
> {code}
> ls: cannot access /home/hudson/tools/java/latest1.7/..: No such file or directory
> {code}
> Messing w/ the options in the jenkins UI and then putting script in text box to expose
paths, almost none of the advertised options are available.
> Something changed.
> I got a 1.7 working by setting jdk7-u51 explicitly and then setting PATH and JAVA_HOME
just before our test script runs (it downloaded it)
> {code}
> ...
> ls $JAVA_HOME/..
> which java
> java -version
> echo $JAVA_HOME
> saveJavaHome=$JAVA_HOME
> $JAVA_HOME/bin/java -version
> ulimit -a
> set +x
> source ${WORKSPACE}/dev-support/jenkinsEnv.sh
> export JAVA_HOME="$saveJavaHome"
> export PATH=$JAVA_HOME/bin:$PATH
> which java
> java -version
> echo "Resetting java_home -- FIX jenkinsEnv.sh!!! $JAVA_HOME"
> ....
> {code}
> HBase builds on hadoop1||hadoop2||hadoop3||hadoop8
> I ain't sure how this stuff is supposed to be set.  Asking Andrew Bayer on our end (He
said 'credits' needed refresh last night but that doesn't seem to have helped here).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message