hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Upgrading Hadoop dependencies and catching potential incompatibilities for HBase
Date Wed, 28 Sep 2016 17:06:20 GMT
Looking at HADOOP-12705, it upgrades jackson2.version.
However, hbase only depends on jackson (1.9.13).

It seems the impact of upgrading jackson2 should be minimal on hbase.

Cheers

On Wed, Sep 28, 2016 at 9:56 AM, Sean Mackrory <mackrorysd@gmail.com> wrote:

> HBase folks,
>
> I'd like to work on upgrading some of the dependencies in Hadoop that are
> starting to lag behind:
>
> jackson2 (https://issues.apache.org/jira/browse/HADOOP-12705)
> jaxb-api (https://issues.apache.org/jira/browse/HADOOP-13659)
> commons-configuration (https://issues.apache.org/jira/browse/HADOOP-13660)
> htrace (https://issues.apache.org/jira/browse/HADOOP-13661)
>
> Some of these (chiefly jackson) are known to be high risk upgrades and have
> caused problems for HBase in the past. I wanted to give you a heads up
> about this work and coordinate with you to make sure I do all the testing
> you think is necessary to discover any potential problems well in advance
> of the breakages.
>
> I was going to look at just running HBase's unit tests when built against
> my Hadoop's trunk with my changes (Should I expect any problems here? Is
> there a branch already focused on Hadoop 3 compatibility or anything?) and
> Bigtop's integration tests too. Anything else you would add to this?
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message