hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gabor Liptak (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-15583) Discuss mutable vs immutable HTableDescriptor
Date Fri, 01 Apr 2016 21:53:25 GMT
Gabor Liptak created HBASE-15583:
------------------------------------

             Summary: Discuss mutable vs immutable HTableDescriptor
                 Key: HBASE-15583
                 URL: https://issues.apache.org/jira/browse/HBASE-15583
             Project: HBase
          Issue Type: Sub-task
    Affects Versions: 2.0.0
            Reporter: Gabor Liptak
            Priority: Minor


>From [~enis] in https://issues.apache.org/jira/browse/HBASE-15505:

    PS Should UnmodifyableHTableDescriptor be renamed to UnmodifiableHTableDescriptor?

It should be named ImmutableHTableDescriptor to be consistent with collections naming. Let's
do this as a subtask of the parent jira, not here. Thinking about it though, why would we
return an Immutable HTD in HTable.getTableDescriptor() versus a mutable HTD in Admin.getTableDescriptor().
It does not make sense. Should we just get rid of the Immutable ones?
We also have UnmodifyableHRegionInfo which is not used at the moment it seems. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message