hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 张铎 <palomino...@gmail.com>
Subject Re: [DISCUSS] hbase-2.0.x requires jdk8
Date Fri, 08 Apr 2016 09:12:25 GMT
+1 on jdk8 only. Bunch of code could be refactored with jdk8's new
features, new classes and new methods.
For example, most 'get->putIfAbsent->checkAndCleanUp' and 'get->lock->get
again->put->unlock' can be replaced by computeIfAbsent.

2016-04-08 16:43 GMT+08:00 Elliott Clark <eclark@apache.org>:

> As a side benefit, only testing one jdk would seriously speed up test runs.
>
> +1
>
> On Thu, Apr 7, 2016 at 10:12 PM, Stack <stack@duboce.net> wrote:
>
> > Is there a YETUS issue for this Sean or should I file one?
> > St.Ack
> >
> > On Thu, Apr 7, 2016 at 9:21 PM, Sean Busbey <busbey@cloudera.com> wrote:
> >
> > > we'll need to get a feature into yetus that can change multijdk
> > > settings by branch, presuming that change will result in us either
> > > taking on jdk8-only dependencies or direct use of jdk8-only features.
> > >
> > > On Thu, Apr 7, 2016 at 9:18 PM, Stack <stack@duboce.net> wrote:
> > > > Any objection?
> > > >
> > > > jdk7 is dead, EOL'd.
> > > >
> > > > You all good w/ this?
> > > >
> > > > St.Ack
> > >
> > >
> > >
> > > --
> > > busbey
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message