hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-15462) Docker-based builds failing...
Date Mon, 14 Mar 2016 20:38:33 GMT
stack created HBASE-15462:
-----------------------------

             Summary: Docker-based builds failing...
                 Key: HBASE-15462
                 URL: https://issues.apache.org/jira/browse/HBASE-15462
             Project: HBase
          Issue Type: Bug
          Components: build
            Reporter: stack


Our hadoopqa builds have been failing the last few days setting up the docker container. Failure
looks like this from console:

{code}
Removing intermediate container 3ae7349600a3
Step 16 : RUN gem install rubocop --no-ri --no-rdoc
 ---> Running in 7c3bedd253b0
Invalid gemspec in [/var/lib/gems/1.9.1/specifications/unicode-display_width-1.0.2.gemspec]:
Illformed requirement ["< 3.0.0, >= 1.9.3"]
Invalid gemspec in [/var/lib/gems/1.9.1/specifications/unicode-display_width-1.0.2.gemspec]:
Illformed requirement ["< 3.0.0, >= 1.9.3"]
Invalid gemspec in [/var/lib/gems/1.9.1/specifications/unicode-display_width-1.0.2.gemspec]:
Illformed requirement ["< 3.0.0, >= 1.9.3"]
ERROR:  Error installing rubocop:
	rubocop requires unicode-display_width (>= 1.0.1, ~> 1.0)
The command '/bin/sh -c gem install rubocop --no-ri --no-rdoc' returned a non-zero code:
1
{code}

Looks fixable?

I changed the config on hadoopqa to not use docker builds in meantime.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message