hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: Testing and CI -- Apache Jenkins Builds (WAS -> Re: Testing)
Date Tue, 19 Jan 2016 17:48:31 GMT
On Tue, Jan 19, 2016 at 5:46 AM, Sean Busbey <busbey@apache.org> wrote:

> We could start forcing a clean repository on every build (though this
> seems heavy handed).
>
> IIRC, we ran into this ages ago and it was one particular dependency.
> Presuming we can track down what that was, we could add some pre-build
> work that verifies a known good copy of that dependency is present.
>
> For now, I've blacklisted the H2 build host again, since that's the
> only host this has been happening on. We added it back last week so
> that Jon could test a fix from infra.
>
>
Thanks Sean.

Yeah, clean repo each time would be OTT.

If you have pointers on how to find the bad dependency, I'll dig.

Of course, all builds fine locally.

St.Ack



> -Sean
>
> On Mon, Jan 18, 2016 at 10:55 PM, Stack <stack@duboce.net> wrote:
> > Anyone know what the refresh timeout is for the below? We seem to be in a
> > phase where we have a bad pom and the hadoop test builds are failing. Can
> > we force refresh of the local repository by doing something like a custom
> > build run?
> >
> > Thanks,
> > St.Ack
> > P.S. Here is what I am talking about:
> >
> https://builds.apache.org/job/PreCommit-HBASE-Build/178/artifact/patchprocess/patch-javac-2.4.0.txt
> > which is from this run today:
> > https://issues.apache.org/jira/browse/HBASE-15086  Thanks
> >
> >
> > On Thu, Nov 5, 2015 at 10:42 AM, Sean Busbey <busbey@cloudera.com>
> wrote:
> >
> >> If Maven has trouble grabbing a pom but not an artifact, it'll
> >> substitute in a placeholder pom that doesn't have e.g. license
> >> information. That can result in a local repo that fails this way until
> >> the refresh timeout hits for grabbing a pom again.
> >>
> >> On Wed, Nov 4, 2015 at 5:33 PM, Stack <stack@duboce.net> wrote:
> >> > Thanks Andrew. Weird is that it is sporadic. Will keep an eye on it.
> >> > St.Ack
> >> >
> >> > On Wed, Nov 4, 2015 at 8:14 AM, Andrew Purtell <
> andrew.purtell@gmail.com
> >> >
> >> > wrote:
> >> >
> >> >> > [ERROR] Error invoking method 'get(java.lang.Integer)' in
> >> >> java.util.ArrayList at META-INF/LICENSE.vm[line 1627, column 22]
> >> >>
> >> >> This means a Velocity macro for building LICENSE info about a
> component
> >> >> has failed because necessary information is missing in the Maven
> model.
> >> >> When I have seen this it has been due to a change in dependencies
> >> without
> >> >> necessary updates to supplemental-models.xml. Running the LICENSE and
> >> >> NOTICE aggregations in debug mode will print out clues as to what
> >> >> specifically is missing. See defines in the POMs for doing so. (I'm
> not
> >> at
> >> >> the computer yet so can't pull up the specifics.)
> >> >>
> >> >>
> >> >> > On Nov 4, 2015, at 6:23 AM, Stack <stack@duboce.net> wrote:
> >> >> >
> >> >> > [ERROR] Error invoking method 'get(java.lang.Integer)' in
> >> >> > java.util.ArrayList at META-INF/LICENSE.vm[line 1627, column 22]
> >> >>
> >>
> >>
> >>
> >> --
> >> Sean
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message