hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup
Date Wed, 16 Dec 2015 22:38:46 GMT
Enis Soztutar created HBASE-14998:
-------------------------------------

             Summary: Unify synchronous and asynchronous methods in Admin and cleanup
                 Key: HBASE-14998
                 URL: https://issues.apache.org/jira/browse/HBASE-14998
             Project: HBase
          Issue Type: Sub-task
            Reporter: Enis Soztutar
             Fix For: 2.0.0


Admin has a bunch of methods, some are asnyc, some are sync. Needs some unification in method
naming, and method signatures. 

 - We use modify and alter interchangeably. Pick one and stick with it (modifyTable(), versus
getAlterStatus()). Shell uses {{alter}}. 
 - Remove getAlterStatus(), should not be needed. 
 - remove already deprecated methods 
 -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be removed. 
 - Consistently use Aysnc as a prefix for all async methods. 
 - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message