hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@cloudera.com>
Subject Re: Testing and CI -- Apache Jenkins Builds
Date Mon, 31 Aug 2015 15:54:30 GMT
and now I've removed H0 from the precommit rotation, because of repeated "I
can't find maven" errors. :/

On Mon, Aug 31, 2015 at 10:01 AM, Sean Busbey <busbey@cloudera.com> wrote:

> FYI, I've changed the precommit test to run using the test-patch.sh file
> from a branch for HBASE-14337 so I can make changes needed to allow the
> workspace to have a maven repo just for our builds (rather than the shared
> one with the jenkins user).
>
> submitted patches are still applied and run against their branch (default
> master).
>
> Once I have a coherent patch I'll post it to HBASE-14337 and we can stop
> using the branch.
>
> On Fri, Aug 21, 2015 at 2:17 PM, Stack <stack@duboce.net> wrote:
>
>> A deadlock was causing TestDistributedLogSplitting to hang. Elliott fixed
>> it over in HBASE-14274. This was the source of the zombie processes
>> reported by INFRA (at least, it matched the one instance they reported).
>>
>> Patch builds were disabled overnight (for a different reason) but are back
>> again.
>>
>> St.Ack
>>
>>
>>
>>
>>
>> On Thu, Aug 20, 2015 at 9:44 AM, Stack <stack@duboce.net> wrote:
>>
>> > On Wed, Aug 19, 2015 at 6:18 PM, Stack <stack@duboce.net> wrote:
>> >
>> >> https://issues.apache.org/jira/browse/BUILDS-109
>> >>
>> >
>> > This became https://issues.apache.org/jira/browse/INFRA-10150 which
>> > becomes BUILDS-111.
>> >
>> > Errant left-over java processes sucking up resources. Trunk is
>> > particularly susceptible because we spin up way more threads than in
>> other
>> > branches (async rpc client). See HBASE-14262 for follow-up.
>> >
>> > St.Ack
>> >
>> >
>> >>
>> >> St.Ack
>> >>
>> >> On Wed, Aug 19, 2015 at 5:38 PM, Stack <stack@duboce.net> wrote:
>> >>
>> >>> On Wed, Aug 19, 2015 at 5:24 PM, Stack <stack@duboce.net> wrote:
>> >>>
>> >>>> On Wed, Aug 19, 2015 at 5:08 PM, Sean Busbey <busbey@cloudera.com>
>> >>>> wrote:
>> >>>>
>> >>>>> I don't recall anything, but I'll go dig through the infra@
list
>> >>>>> later this
>> >>>>> evening to make sure.
>> >>>>>
>> >>>>> Is this on all the H* build hosts?
>> >>>>>
>> >>>>>
>> >>>> Seemingly, yes.
>> >>>>
>> >>>> I can look at infra changes, no prob. Sean. Was just wondering if
>> >>>> anyone knew of a change.
>> >>>>
>> >>>>
>> >>> I don't see anything in INFRA JIRA mailing list related.
>> >>>
>> >>> Let me file an INFRA BUILDS issue and see if anything comes of it.
>> >>>
>> >>> St.Ack
>> >>>
>> >>>
>> >>>
>> >>>> Thanks,
>> >>>> St.Ack
>> >>>>
>> >>>>
>> >>>>
>> >>>>> On Wed, Aug 19, 2015 at 7:05 PM, Stack <stack@duboce.net>
wrote:
>> >>>>>
>> >>>>> > Trunk builds are failing with OOME, can't create native
thread
>> >>>>> > (HBASE-14262)
>> >>>>> >
>> >>>>> > Anyone know of any recent INFRA changes?
>> >>>>> >
>> >>>>> > Imperfect triage has our problem starting in build #15134,
Aug 18,
>> >>>>> 2015
>> >>>>> > 5:10:02 AM
>> >>>>> >
>> >>>>> > Otherwise, was going to mess with heap sizings and trying
to make
>> >>>>> the big
>> >>>>> > tests smaller so we can get trunk passing again.
>> >>>>> >
>> >>>>> > Thanks,
>> >>>>> > St.Ack
>> >>>>> >
>> >>>>>
>> >>>>>
>> >>>>>
>> >>>>> --
>> >>>>> Sean
>> >>>>>
>> >>>>
>> >>>>
>> >>>
>> >>
>> >
>>
>
>
>
> --
> Sean
>



-- 
Sean

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message