hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ramkrishna vasudevan <ramkrishna.s.vasude...@gmail.com>
Subject Re: Creating tar ball has issues
Date Thu, 30 Jul 2015 03:49:58 GMT
Really apprciate it Ted. Not sure why it was notworking, with a clean
checkout today it started working.  May be some issues in my work branch.

Regards
Ram



On Thu, Jul 30, 2015 at 12:09 AM, Ted Yu <yuzhihong@gmail.com> wrote:

> For Java 8, the following commands work:
>
>  1018  mvn clean install -DskipTests -Prelease,build-with-jdk8
> -DcompileSource=1.8
>  1020  mvn install assembly:single -DskipTests -Prelease,build-with-jdk8
> -DcompileSource=1.8
>
> FYI
>
> On Wed, Jul 29, 2015 at 11:21 AM, Ted Yu <yuzhihong@gmail.com> wrote:
>
> > If Java 1.8 is used, I encounter the following error:
> >
> > [INFO] Restricted to JDK 1.7 yet jdk.tools:jdk.tools:jar:1.8:system
> > contains com/sun/javadoc/package-info.class targeted to JDK 1.8
> > [WARNING] Rule 0:
> org.apache.maven.plugins.enforcer.EnforceBytecodeVersion
> > failed with message:
> > HBase has unsupported dependencies.
> >   HBase requires that all dependencies be compiled with version 1.7 or
> > earlier
> >   of the JDK to properly build from source.  You appear to be using a
> > newer dependency. You can use
> >   either "mvn -version" or "mvn enforcer:display-info" to verify what
> > version is active.
> >   Non-release builds can temporarily build with a newer JDK version by
> > setting the
> >   'compileSource' property (eg. mvn -DcompileSource=1.8 clean package).
> > Found Banned Dependency: jdk.tools:jdk.tools:jar:1.8
> >
> > I get the same error when specifying -Pbuild-with-jdk8
> >
> > FYI
> >
> > On Wed, Jul 29, 2015 at 10:31 AM, Ted Yu <yuzhihong@gmail.com> wrote:
> >
> >> For a fresh checkout, I did:
> >>
> >>  1020  mvn install -DskipTests -Prelease
> >>  1021  mvn install -DskipTests assembly:single -Prelease
> >>
> >> hbase-assembly/target/hbase-2.0.0-SNAPSHOT-bin.tar.gz was generated.
> >> I used Java 1.7
> >>
> >> What commands did you use ?
> >>
> >> Cheers
> >>
> >> On Wed, Jul 29, 2015 at 10:12 AM, ramkrishna vasudevan <
> >> ramkrishna.s.vasudevan@gmail.com> wrote:
> >>
> >>> Hi All
> >>>
> >>> I am trying to create the tar ball from the latest master.
> >>> I am getting this error
> >>> ERROR] Failed to execute goal
> >>> org.apache.maven.plugins:maven-assembly-plugin:2.4:single (default-cli)
> >>> on
> >>> project hbase-assembly: Failed to create assembly: Error creating
> >>> assembly
> >>> archive bin: Problem creating TAR: request to write '8192' bytes
> exceeds
> >>> size in header of '1200647934' bytes -> [Help 1]
> >>> [ERROR]
> >>> [ERROR] To see the full stack trace of the errors, re-run Maven with
> the
> >>> -e
> >>> switch.
> >>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> >>>
> >>> Is it for me alone?
> >>>
> >>> Regards
> >>> Ram
> >>>
> >>
> >>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message