hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-13963) use jdk appropriate version of jdk.tools and avoid leaking it
Date Wed, 24 Jun 2015 18:58:04 GMT
Sean Busbey created HBASE-13963:
-----------------------------------

             Summary: use jdk appropriate version of jdk.tools and avoid leaking it
                 Key: HBASE-13963
                 URL: https://issues.apache.org/jira/browse/HBASE-13963
             Project: HBase
          Issue Type: Sub-task
          Components: build, documentation
            Reporter: Sean Busbey
            Priority: Critical
             Fix For: 2.0.0, 1.2.0, 1.3.0


Right now hbase-annotations uses jdk7 jdk.tools and exposes that to downstream via hbase-client.
We need it for building and using our custom doclet, but can improve a couple of things: 

1) We should be using a jdk.tools version based on our java version (use jdk activated profiles
to set it)

2) We should not be including any jdk.tools version in our hbase-client transitive dependencies
(or other downstream-facing artifacts). Unfortunately, system dependencies are included in
transitive resolution, so we'll need to exclude it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message