hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Francke (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-13645) Rename *column methods in MasterObserver to *columnFamily
Date Fri, 08 May 2015 07:10:00 GMT
Lars Francke created HBASE-13645:
------------------------------------

             Summary: Rename *column methods in MasterObserver to *columnFamily
                 Key: HBASE-13645
                 URL: https://issues.apache.org/jira/browse/HBASE-13645
             Project: HBase
          Issue Type: Improvement
            Reporter: Lars Francke
            Priority: Minor


This being an interface makes it a bit harder on implementors. It'd be easier with Java8 and
default implementations.

We could either

# add new *columnFamily methods and deprecate the old ones or
# rename the existing ones without doing a deprecation first.

Implementors would need to change their code in each of those cases. But because we have the
{{BaseMasterObserver}} and {{BaseMasterAndRegionObserver}} it'd make things easier for people
using those classes if we go with option 1. So that's my preference.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message