hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Newcomer (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-13577) Hbase Documentation Is Wrong :(
Date Mon, 27 Apr 2015 20:04:38 GMT
David Newcomer created HBASE-13577:
--------------------------------------

             Summary: Hbase Documentation Is Wrong :(
                 Key: HBASE-13577
                 URL: https://issues.apache.org/jira/browse/HBASE-13577
             Project: HBase
          Issue Type: Bug
          Components: documentation
    Affects Versions: 1.0.0
            Reporter: David Newcomer
            Priority: Minor


At the bottom of section 2.4 in the Hbase Documentation, there is a section about Browsing
the web UI that makes several references to port 16610. 

http://hbase.apache.org/book.html#quickstart_fully_distributed

<DOCUMENTATION>
"In HBase newer than 0.98.x, the HTTP ports used by the HBase Web UI changed from 60010 for
the Master and 60030 for each RegionServer to 16610 for the Master and 16030 for the RegionServer.

If everything is set up correctly, you should be able to connect to the UI for the Master
http://node-a.example.com:16610/ or the secondary master at http://node-b.example.com:16610/
for the secondary master, using a web browser. If you can connect via localhost but not from
another host, check your firewall rules. You can see the web UI for each of the RegionServers
at port 16630 of their IP addresses, or by clicking their links in the web UI for the Master."
</DOCUMENTATION>

This is the wrong port; it should instead be 16010. The correct port is listed in Section
6: http://hbase.apache.org/book.html#confirm

This might seem like a pretty minor issue, but it took me a couple hours to figure out.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message