hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Lawlor (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-13442) Rename scanner caching to a more semantically correct term such as row limit
Date Thu, 23 Apr 2015 16:49:39 GMT

     [ https://issues.apache.org/jira/browse/HBASE-13442?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Lawlor resolved HBASE-13442.
-------------------------------------
    Resolution: Duplicate

Closing this one in favor of HBASE-13541. Please reopen if there are any outstanding concerns.

> Rename scanner caching to a more semantically correct term such as row limit
> ----------------------------------------------------------------------------
>
>                 Key: HBASE-13442
>                 URL: https://issues.apache.org/jira/browse/HBASE-13442
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Jonathan Lawlor
>         Attachments: HBASE-13442-proposal.diff
>
>
> Caching acts more as a row limit now. By default in branch-1+, a Scan is configured with
(caching=Integer.MAX_VALUE, maxResultSize=2MB) so that we service scans on the basis of buffer
size rather than number of rows. As a result, caching should now only be configured in instances
where the user knows that they will only need X rows. Thus, caching should be renamed to something
that is more semantically correct such as rowLimit.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message