hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-5301) Some RegionServer metrics have really confusing names
Date Sat, 11 Apr 2015 01:13:13 GMT

     [ https://issues.apache.org/jira/browse/HBASE-5301?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Andrew Purtell resolved HBASE-5301.
    Resolution: Not A Problem

> Some RegionServer metrics have really confusing names
> -----------------------------------------------------
>                 Key: HBASE-5301
>                 URL: https://issues.apache.org/jira/browse/HBASE-5301
>             Project: HBase
>          Issue Type: Bug
>          Components: metrics
>            Reporter: Doug Meil
>              Labels: metrics
> Mikael Sitruk commented on this back in Nov 2011 and after looking at this I completely
agree with him.  For example, "flushSize_avg_time" makes no sense.  "flushSize" is in bytes,
so is this the average flush size?  Or the average time per flush?  In which case, why not
call the measure "flush_avg_time".  But to add to the confusion there is already a "flushTime_avg_time"
metric.  There is also "flushTime_num_ops" and "flushSize_num_ops" that are confusing.  Is
the former the number of flushes?  In which case, why have "time" in the metric name?  
> On 11/22/11 5:23 PM, "Mikael Sitruk" <mikael.sitruk@gmail.com> wrote:
> Hi
> I have enabled metrics on Hbase cluster (0.90.1), and mapped the metrics
> to
> 3 categories (missing, Present but not documented/Incomplete
> documentation,Ok) according to their status in the book (
> http://hbase.apache.org/book.html#hbase_metrics). Is it possible to udpate
> the book accordingly?
> It seems also that rpc metrics are not documented at all.
> And now some questions on the metrics:
> I can see some metrics present a num_ops and avg_time suffix (like rpc)
> but
> it seems that for certain metrics is it totally unclear (to me at least)
> or
> their name is missleading - for example what
> means compactionTime_avg_time/compactionTime_num_ops? or
> flushSize_avg_time
> and flushSize_num_ops? I mean I would have understood compaction_avg_time
> and flushSize or flush_avg_time.

This message was sent by Atlassian JIRA

View raw message