hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Srikanth Srungarapu <srikanth...@gmail.com>
Subject Re: Hadoop-qa bot sometimes doesn't notice patches?
Date Thu, 09 Apr 2015 04:56:46 GMT
Yeah, Sean is right. It aborts if the attachment is already tested once.
Sample error message.

> Attachment 12723874 is already tested for HBASE-13423
> Build step 'Execute shell' marked build as failure
> Archiving artifacts
> Sending artifact delta relative to PreCommit-HBASE-Build #13621
> Archived 28 artifacts
> Archive block size is 32768
> Received 9 blocks and 207014 bytes
> Compression is 58.8%
> Took 3.5 sec
> Recording test results
> [description-setter] Could not determine description.
> Finished: FAILURE
>

On Wed, Apr 8, 2015 at 9:37 PM, Sean Busbey <busbey@cloudera.com> wrote:

> You can check the Jenkins log to be sure, but the patch tester has a check
> now that short-circuit aborts test runs when it has already seen a specific
> JIRA attachment.
>
> --
> Sean
> On Apr 8, 2015 11:32 PM, "Mikhail Antonov" <olorinbant@gmail.com> wrote:
>
> > Hm, I see, that's interesting. Thanks Ted.
> >
> > Though I think I observed this behavior with patches not being picked
> > up during several last weeks at least.
> >
> > -Mikhail
> >
> > On Wed, Apr 8, 2015 at 9:27 PM, Ted Yu <yuzhihong@gmail.com> wrote:
> > > Today git repo temporarily was inaccessible.
> > > e.g. from
> > https://builds.apache.org/job/PreCommit-HBASE-Build/13626/console
> > >
> > > FATAL: Failed to fetch from
> > >
> >
> https://git-wip-us.apache.org/repos/asf/hbase.githudson.plugins.git.GitException
> > :
> > > Failed to fetch from
> > > https://git-wip-us.apache.org/repos/asf/hbase.git       at
> > > hudson.plugins.git.GitSCM.fetchFrom(GitSCM.java:647)
> > >         at hudson.plugins.git.GitSCM.retrieveChanges(GitSCM.java:889)
> > >
> > >
> > > FYI
> > >
> > >
> > > On Wed, Apr 8, 2015 at 9:22 PM, Mikhail Antonov <olorinbant@gmail.com>
> > > wrote:
> > >
> > >> Hey guys,
> > >>
> > >> I think hadoop-qa used to pick up and run the last attached patch when
> > >> you click cancel/submit patch. Lately I've noticed that (sometimes?)
> > >> doesn't work - you'd need to re-attach the same file first and then
> > >> click cancel/submit.
> > >>
> > >> Anyone else observed that? Is it some kind of misconfiguration or
> > >> something else?
> > >>
> > >> -Mikhail
> > >>
> >
> >
> >
> > --
> > Thanks,
> > Michael Antonov
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message