hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bo Fu <...@uchicago.edu>
Subject Re: Base can't start due to Zookeeper
Date Tue, 21 Apr 2015 20:57:34 GMT
Exactly! I added one more zookeeper and it just worked. Thank Jinal and Ted

Bo


> On Apr 21, 2015, at 2:25 PM, Jinal Shah <jinalshah2007@gmail.com> wrote:
> 
> You only have 2 zookeeper nodes in your quoram. You need atleast 3 nodes.
> That's your problem.
> 
> On Tue, Apr 21, 2015 at 12:18 PM Ted Yu <yuzhihong@gmail.com> wrote:
> 
>> bq. <value>pc440.emulab.net<http://pc440.emulab.net>,pc439.emulab.net<
>> http://pc439.emulab.net></value>
>> 
>> Please confirm whether the above is the actual content in hbase-site.xml
>> Looks like the quorum is badly formatted.
>> 
>> Cheers
>> 
>> On Tue, Apr 21, 2015 at 11:38 AM, Bo Fu <bof@uchicago.edu> wrote:
>> 
>>> Hi,
>>> 
>>> I’m a beginner of HBase. I’m recently deploying HBase 1.0.0 onto Emulab
>>> using Hadoop 2.6.0
>>> When I type bin/start-hbase.sh, Hbase and HRegionservers starts and then
>>> shut down. The master log are as follows:
>>> 
>>> 2015-04-21 12:13:58,607 INFO  [main-SendThread(pc439.emulab.net<
>>> http://pc439.emulab.net>:2181)] zookeeper.ClientCnxn: Opening socket
>>> connection to server pc439.emulab.net/155.98.38.39:2181<
>>> http://pc439.emulab.net/155.98.38.39:2181>. Will not attempt to
>>> authenticate using SASL (unknown error)
>>> 2015-04-21 12:13:58,608 INFO  [main-SendThread(pc439.emulab.net<
>>> http://pc439.emulab.net>:2181)] zookeeper.ClientCnxn: Socket connection
>>> established to pc439.emulab.net/155.98.38.39:2181<
>>> http://pc439.emulab.net/155.98.38.39:2181>, initiating session
>>> 2015-04-21 12:13:58,609 INFO  [main-SendThread(pc439.emulab.net<
>>> http://pc439.emulab.net>:2181)] zookeeper.ClientCnxn: Unable to read
>>> additional data from server sessionid 0x0, likely server has closed
>> socket,
>>> closing socket connection and attempting reconnect
>>> 2015-04-21 12:13:59,513 INFO  [main-SendThread(pc440.emulab.net<
>>> http://pc440.emulab.net>:2181)] zookeeper.ClientCnxn: Opening socket
>>> connection to server pc440.emulab.net/155.98.38.40:2181<
>>> http://pc440.emulab.net/155.98.38.40:2181>. Will not attempt to
>>> authenticate using SASL (unknown error)
>>> 2015-04-21 12:13:59,513 INFO  [main-SendThread(pc440.emulab.net<
>>> http://pc440.emulab.net>:2181)] zookeeper.ClientCnxn: Socket connection
>>> established to pc440.emulab.net/155.98.38.40:2181<
>>> http://pc440.emulab.net/155.98.38.40:2181>, initiating session
>>> 2015-04-21 12:13:59,514 INFO  [main-SendThread(pc440.emulab.net<
>>> http://pc440.emulab.net>:2181)] zookeeper.ClientCnxn: Unable to read
>>> additional data from server sessionid 0x0, likely server has closed
>> socket,
>>> closing socket connection and attempting reconnect
>>> 2015-04-21 12:14:01,531 INFO  [main-SendThread(pc439.emulab.net<
>>> http://pc439.emulab.net>:2181)] zookeeper.ClientCnxn: Opening socket
>>> connection to server pc439.emulab.net/155.98.38.39:2181<
>>> http://pc439.emulab.net/155.98.38.39:2181>. Will not attempt to
>>> authenticate using SASL (unknown error)
>>> 2015-04-21 12:14:01,531 INFO  [main-SendThread(pc439.emulab.net<
>>> http://pc439.emulab.net>:2181)] zookeeper.ClientCnxn: Socket connection
>>> established to pc439.emulab.net/155.98.38.39:2181<
>>> http://pc439.emulab.net/155.98.38.39:2181>, initiating session
>>> 2015-04-21 12:14:01,532 INFO  [main-SendThread(pc439.emulab.net<
>>> http://pc439.emulab.net>:2181)] zookeeper.ClientCnxn: Unable to read
>>> additional data from server sessionid 0x0, likely server has closed
>> socket,
>>> closing socket connection and attempting reconnect
>>> 2015-04-21 12:14:01,633 WARN  [main] zookeeper.RecoverableZooKeeper:
>>> Possibly transient ZooKeeper, quorum=pc439.emulab.net<
>>> http://pc439.emulab.net>:2181,pc440.emulab.net<http://pc440.emulab.net
>>> :2181,
>>> exception=org.apache.zookeeper.KeeperException$ConnectionLossException:
>>> KeeperErrorCode = ConnectionLoss for /hbase
>>> 2015-04-21 12:14:01,633 ERROR [main] zookeeper.RecoverableZooKeeper:
>>> ZooKeeper create failed after 4 attempts
>>> 2015-04-21 12:14:01,634 ERROR [main] master.HMasterCommandLine: Master
>>> exiting
>>> java.lang.RuntimeException: Failed construction of Master: class
>>> org.apache.hadoop.hbase.master.HMaster
>>>        at
>>> org.apache.hadoop.hbase.master.HMaster.constructMaster(HMaster.java:1982)
>>>        at
>>> 
>> org.apache.hadoop.hbase.master.HMasterCommandLine.startMaster(HMasterCommandLine.java:198)
>>>        at
>>> 
>> org.apache.hadoop.hbase.master.HMasterCommandLine.run(HMasterCommandLine.java:139)
>>>        at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
>>>        at
>>> 
>> org.apache.hadoop.hbase.util.ServerCommandLine.doMain(ServerCommandLine.java:126)
>>>        at org.apache.hadoop.hbase.master.HMaster.main(HMaster.java:1996)
>>> Caused by: org.apache.zookeeper.KeeperException$ConnectionLossException:
>>> KeeperErrorCode = ConnectionLoss for /hbase
>>>        at
>>> org.apache.zookeeper.KeeperException.create(KeeperException.java:99)
>>>        at
>>> org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
>>>        at org.apache.zookeeper.ZooKeeper.create(ZooKeeper.java:783)
>>>        at
>>> 
>> org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper.createNonSequential(RecoverableZooKeeper.java:512)
>>>        at
>>> 
>> org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper.create(RecoverableZooKeeper.java:491)
>>>        at
>>> 
>> org.apache.hadoop.hbase.zookeeper.ZKUtil.createWithParents(ZKUtil.java:1252)
>>>        at
>>> 
>> org.apache.hadoop.hbase.zookeeper.ZKUtil.createWithParents(ZKUtil.java:1230)
>>>        at
>>> 
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWatcher.createBaseZNodes(ZooKeeperWatcher.java:174)
>>>        at
>>> 
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWatcher.<init>(ZooKeeperWatcher.java:167)
>>> 
>>> My Hbase-site.xml is:
>>> <configuration>
>>>  <property>
>>>    <name>hbase.master</name>
>>>    <value>10.10.10.2:60000</value>
>>>  </property>
>>>  <property>
>>>    <name>hbase.rootdir</name>
>>>    <value>hdfs://hadoopmaster:9000/hbase</value>
>>>  </property>
>>>  <property>
>>>    <name>hbase.zookeeper.property.dataDir</name>
>>>    <value>/proj/ucare/bo/hadoop_data/zookeeper</value>
>>>  </property>
>>>  <property>
>>>    <name>hbase.zookeeper.quorum</name>
>>>    <value>pc440.emulab.net<http://pc440.emulab.net>,pc439.emulab.net<
>>> http://pc439.emulab.net></value>
>>>    <description>The directory shared by RegionServers.
>>> </description>
>>>  </property>
>>>  <property>
>>>    <name>hbase.cluster.distributed</name>
>>>    <value>true</value>
>>>  </property>
>>>  <property>
>>>    <name>dfs.replication</name>
>>>    <value>1</value>
>>>  </property>
>>> </configuration>
>>> 
>>> The regionservers file is:
>>> 
>>> BF@pc440.emulab.net<mailto:BF@pc440.emulab.net>
>>> BF@pc439.emulab.net<mailto:BF@pc439.emulab.net>
>>> 
>>> Someone could tell me how to fix it?
>>> 
>>> Thanks a lot!
>>> 
>>> Bo
>>> 
>>> 
>> 

Mime
View raw message