hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars George (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-13346) Clean up Filter package for post 1.0
Date Fri, 27 Mar 2015 09:11:53 GMT
Lars George created HBASE-13346:
-----------------------------------

             Summary: Clean up Filter package for post 1.0
                 Key: HBASE-13346
                 URL: https://issues.apache.org/jira/browse/HBASE-13346
             Project: HBase
          Issue Type: Bug
          Components: API, Filters
    Affects Versions: 2.0.0
            Reporter: Lars George
             Fix For: 2.0.0


Since we have a bit of a messy Filter API with KeyValue vs Cell reference mixed up all over
the place, I recommend cleaning this up once and for all. There should be no {{KeyValue}}
(or {{kv}}, {{kvs}} etc.) in any method or parameter name.

This includes deprecating and renaming filters too, for example {{FirstKeyOnlyFilter}}, which
really should be named {{FirstKeyValueFilter}} as it does _not_ just return the key, but the
entire cell. It should be deprecated and renamed to {{FirstCellFilter}} (or {{FirstColumnFilter}}
if you prefer).

In general we should clarify and settle on {{KeyValue}} vs {{Cell}} vs {{Column}} in our naming.
The latter two are the only ones going forward with the public API, and are used synonymous.
We should carefully check which is better suited (is it really a specific cell, or the newest
cell, aka the newest column value) and settle on a naming schema.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message