hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-13270) Setter for Result#getStats is #addResults; confusing!
Date Wed, 18 Mar 2015 18:21:39 GMT
stack created HBASE-13270:

             Summary: Setter for Result#getStats is #addResults; confusing!
                 Key: HBASE-13270
                 URL: https://issues.apache.org/jira/browse/HBASE-13270
             Project: HBase
          Issue Type: Improvement
            Reporter: stack

Below is our [~larsgeorge] on a finding he made reviewing our API:

"Result class having getStats() and addResults(Stats) makes little sense..."

"...the naming is just weird. You have a getStats() getter and an addResults(Stats) setter???"

"...Especially in the Result class and addResult() is plain misleading..."

This issue is about deprecating addResults and replacing it with addStats in its place.

The getStats/addResult is recent. It came in with:

commit a411227b0ebf78b4ee8ae7179e162b54734e77de
Author: Jesse Yates <jesse.k.yates@gmail.com>
Date:   Tue Oct 28 16:14:16 2014 -0700

    HBASE-5162 Basic client pushback mechanism

RegionLoadStats don't belong in Result if you ask me but better in the enveloping on invocations...
but that is another issue.

This message was sent by Atlassian JIRA

View raw message