hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Esteban Gutierrez (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-13139) Clean up missing JAVA_HOME message in bin/hbase-config.sh
Date Mon, 02 Mar 2015 19:30:05 GMT
Esteban Gutierrez created HBASE-13139:
-----------------------------------------

             Summary: Clean up missing JAVA_HOME message in bin/hbase-config.sh
                 Key: HBASE-13139
                 URL: https://issues.apache.org/jira/browse/HBASE-13139
             Project: HBase
          Issue Type: Bug
          Components: shell
    Affects Versions: 0.98.10.1, 1.0.0, 2.0.0
            Reporter: Esteban Gutierrez
            Priority: Trivial


The message needs to be consisten to what the script does:

Currently we say:

{code}
# Now having JAVA_HOME defined is required
if [ -z "$JAVA_HOME" ]; then
    cat 1>&2 <<EOF
+======================================================================+
|      Error: JAVA_HOME is not set and Java could not be found         |
+----------------------------------------------------------------------+
| Please download the latest Sun JDK from the Sun Java web site        |
|       > http://java.sun.com/javase/downloads/ <                      |
|                                                                      |
| HBase requires Java 1.7 or later.                                    |
| NOTE: This script will find Sun Java whether you install using the   |
|       binary or the RPM based installer.                             |
+======================================================================+
EOF
{code}

this should be more like this:
{code}
+======================================================================+
|                    Error: JAVA_HOME is not set                       |
+----------------------------------------------------------------------+
| Please download the latest Sun JDK from the Sun Java web site        |
|       > http://java.sun.com/javase/downloads/ <                      |
|                                                                      |
| HBase requires Java 1.7 or later.                                    |
+======================================================================+
{code}




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message