hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hsieh (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-12646) SnapshotInfo tool does not find mob data in snapshots
Date Sat, 06 Dec 2014 01:22:14 GMT
Jonathan Hsieh created HBASE-12646:
--------------------------------------

             Summary: SnapshotInfo tool does not find mob data in snapshots
                 Key: HBASE-12646
                 URL: https://issues.apache.org/jira/browse/HBASE-12646
             Project: HBase
          Issue Type: Sub-task
          Components: mob, snapshots
    Affects Versions: hbase-11339
            Reporter: Jonathan Hsieh
            Assignee: Jonathan Hsieh
             Fix For: hbase-11339


After taking a snapshot against a table with mob file data, the SnapshotInfo tool is not able
to find the mob files even though they are present in the proper place.  (<hbase>/mobdir/data/dfault/<table>/<region>/....)

Here's an example command line execution:

{code}
[jon@a1210 hbase]$ bin/hbase org.apache.hadoop.hbase.snapshot.SnapshotInfo -snapshot test
-files
....
       - IntegrationTestIngestWithMOB/e9b5d936e7f55a4f1c3246a8d5ce53c2/test_cf/e75380c6db50db845dbdee48ab49381420141205f87d1b47b0f446c7acb3fa0656fa8a57
(NOT FOUND)

**************************************************************
BAD SNAPSHOT: 145 hfile(s) and 0 log(s) missing.
              0 hfile(s) corrupted.
**************************************************************
54 HFiles (54 in archive), total size 973.6 M (0.00% 0 shared with the source table)
0 Logs, total size 0
{code}

The missing files are actually present, it is likely that the snapshot tool doesn't know to
look in the mob dir.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message