hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 张铎 <palomino...@gmail.com>
Subject Re: Not able to create a table in a single node set up with trunk
Date Fri, 07 Nov 2014 13:55:34 GMT
You need to use different hbase-site.xml for master and regionserver, which
means you should make two install directories, one for master and one for
regionserver.

The main reason is hbase.regionserver.port and hbase.regionserver.info.port
must be different(otherwise you will get "java.net.BindException: Address
already in use")...

I tried just now and it works. 26020 is the system regionserver which is
started in the same process of master, 36020 is a regionserver which is
started on the same machine.

ServerNameStart timeRequests Per SecondNum. Regions
hdb177.hy01,26020,1415246110120 <http://hdb177.hy01:26030/rs-status>Thu Nov
06 11:55:10 CST 201402hdb177.hy01,36020,1415367654355
<http://hdb177.hy01:36030/rs-status>Fri Nov 07 21:40:54 CST 201401Total:203

2014-11-07 14:09 GMT+08:00 ramkrishna vasudevan <
ramkrishna.s.vasudevan@gmail.com>:

> Hi
>
> In the current trunk version, where we have the master acting itself as a
> region server does not allow to assign any usertables in a single node
> setup.
>
> Is it by design now so that master table only hosts SYSTEM tables?
>
> So a single RS node setup would mean that the master and RS should be on
> different nodes only.
>
> Regards
> Ram
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message