hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Qiang Tian <tian...@gmail.com>
Subject Re: Not able to run TestHCM locally
Date Tue, 28 Oct 2014 09:18:55 GMT
Please see HBASE-12359

On Tue, Oct 28, 2014 at 4:35 PM, ashish singhi <ashish.singhi@huawei.com>
wrote:

> Yes it may be related to windows.
>
> I Just now ran on Linux. It is passing there.
>
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
>
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
> Running org.apache.hadoop.hbase.client.TestHCM
> Tests run: 21, Failures: 0, Errors: 0, Skipped: 2, Time elapsed: 170.229
> sec - in org.apache.hadoop.hbase.client.TestHCM
>
> Results :
>
> Tests run: 21, Failures: 0, Errors: 0, Skipped: 2
>
> -----Original Message-----
> From: Qiang Tian [mailto:tianq01@gmail.com]
> Sent: 28 October 2014 13:36
> To: dev@hbase.apache.org
> Subject: Re: Not able to run TestHCM locally
>
> I am  running UT on master branch on Linux VM. it passed:
> Tests run: 21, Failures: 0, Errors: 0, Skipped: 2, Time elapsed: 172.968
> sec - in org.apache.hadoop.hbase.client.TestHCM
>
> related to windows?
>
>
>
>
> On Tue, Oct 28, 2014 at 4:03 PM, ashish singhi <ashish.singhi@huawei.com>
> wrote:
>
> > Hi Dima.
> > Thanks for the response
> >
> > I am running on eclipse using junit, Windows 7, Java 1.7.0_17, Maven
> 3.0.3.
> > RAM-4GB, 4 CPUs
> >
> > Regards
> > Ashish
> >
> > -----Original Message-----
> > From: Dima Spivak [mailto:dspivak@cloudera.com]
> > Sent: 28 October 2014 13:24
> > To: dev@hbase.apache.org
> > Subject: Re: Not able to run TestHCM locally
> >
> > Hey Ashish,
> >
> > Can you describe how you're trying to run the test? That is, which OS,
> > Java, and Maven combination? And how much memory/CPU does your system
> have?
> >
> > Cheers,
> >    Dima
> >
> > On Mon, Oct 27, 2014 at 11:58 PM, ashish singhi
> > <ashish.singhi@huawei.com>
> > wrote:
> >
> > > Hi all.
> > >
> > > I am trying to run TestHCM from master branch on my windows.
> > > But the hbase cluster fails to start with below exception.
> > >
> > > 014-10-28 12:21:47,337 ERROR [main] hbase.MiniHBaseCluster(230):
> > > Error starting cluster
> > > java.lang.RuntimeException: Failed construction of Master: class
> > > org.apache.hadoop.hbase.master.HMaster
> > >        at
> > >
> > org.apache.hadoop.hbase.util.JVMClusterUtil.createMasterThread(JVMClus
> > terUtil.java:145)
> > >        at
> > >
> > org.apache.hadoop.hbase.LocalHBaseCluster.addMaster(LocalHBaseCluster.
> > java:215)
> > >        at
> > >
> > org.apache.hadoop.hbase.LocalHBaseCluster.<init>(LocalHBaseCluster.jav
> > a:153)
> > >        at
> > >
> org.apache.hadoop.hbase.MiniHBaseCluster.init(MiniHBaseCluster.java:215)
> > >        at
> > >
> org.apache.hadoop.hbase.MiniHBaseCluster.<init>(MiniHBaseCluster.java:94)
> > >        at
> > >
> > org.apache.hadoop.hbase.HBaseTestingUtility.startMiniHBaseCluster(HBas
> > eTestingUtility.java:914)
> > >        at
> > >
> > org.apache.hadoop.hbase.HBaseTestingUtility.startMiniCluster(HBaseTest
> > ingUtility.java:877)
> > >        at
> > >
> > org.apache.hadoop.hbase.HBaseTestingUtility.startMiniCluster(HBaseTest
> > ingUtility.java:794)
> > >        at
> > >
> > org.apache.hadoop.hbase.HBaseTestingUtility.startMiniCluster(HBaseTest
> > ingUtility.java:765)
> > >        at
> > >
> > org.apache.hadoop.hbase.HBaseTestingUtility.startMiniCluster(HBaseTest
> > ingUtility.java:752)
> > >        at
> > >
> org.apache.hadoop.hbase.client.TestHCM.setUpBeforeClass(TestHCM.java:138)
> > >        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> > >        at
> > >
> > sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.j
> > ava:57)
> > >        at
> > >
> > sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccess
> > orImpl.java:43)
> > >        at java.lang.reflect.Method.invoke(Method.java:601)
> > >        at
> > >
> > org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkM
> > ethod.java:47)
> > >        at
> > >
> > org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCall
> > able.java:12)
> > >        at
> > >
> > org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMet
> > hod.java:44)
> > >        at
> > >
> > org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.j
> > ava:24)
> > >        at
> > >
> > org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.jav
> > a:27)
> > >        at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
> > >        at
> > >
> > org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4T
> > estReference.java:50)
> > >        at
> > >
> > org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.
> > java:38)
> > >        at
> > >
> > org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(Remote
> > TestRunner.java:467)
> > >        at
> > >
> > org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(Remote
> > TestRunner.java:683)
> > >        at
> > >
> > org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestR
> > unner.java:390)
> > >        at
> > > org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTe
> > > st
> > > Runner.java:197) Caused by: java.lang.IllegalArgumentException: IPv6
> > > socket cannot join
> > > IPv4 multicast group
> > >        at
> > > sun.nio.ch.DatagramChannelImpl.innerJoin(DatagramChannelImpl.java:779)
> > >        at
> > sun.nio.ch.DatagramChannelImpl.join(DatagramChannelImpl.java:865)
> > >        at
> > >
> > io.netty.channel.socket.nio.NioDatagramChannel.joinGroup(NioDatagramCh
> > annel.java:394)
> > >        at
> > >
> > org.apache.hadoop.hbase.master.ClusterStatusPublisher$MulticastPublish
> > er.connect(ClusterStatusPublisher.java:273)
> > >        at
> > >
> > org.apache.hadoop.hbase.master.ClusterStatusPublisher.<init>(ClusterSt
> > atusPublisher.java:121)
> > >        at
> org.apache.hadoop.hbase.master.HMaster.<init>(HMaster.java:307)
> > >        at
> > > sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
> > > Method)
> > >        at
> > >
> > sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructo
> > rAccessorImpl.java:57)
> > >        at
> > >
> > sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingCo
> > nstructorAccessorImpl.java:45)
> > >        at
> java.lang.reflect.Constructor.newInstance(Constructor.java:525)
> > >        at
> > >
> > org.apache.hadoop.hbase.util.JVMClusterUtil.createMasterThread(JVMClus
> > terUtil.java:142)
> > >        ... 26 more
> > >
> > > Can some one please help me to resolve this ?
> > >
> > > Regards,
> > > Ashish
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message