hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Could not locate winutils
Date Mon, 06 Oct 2014 16:20:49 GMT
Can you take a look at the last comment in HADOOP-10133 ?

On Mon, Oct 6, 2014 at 2:57 AM, jeevi tesh <jeevitesh.ms@gmail.com> wrote:

> Thanks for the helping hand.
> I have installed
> Hadoop-2.2.0
> hbase-0.96.2-hadoop2-bin
> But I don't want to install hadoop in windows system I have already
> installed above version in linux(oracle linux).
> And I'm able to create table in hbase and list also table in hbase shell.
> And In Bashrc file  I have added the location to the bin of hadoop,hbase.
> I guess you understood my issue.
> I'm trying to connect or open connection from windows7(through kundera)
> system to linux system where hadoop is installed.
> And I get following error
> 2014-10-06 13:29:58,612 ERROR [localhost-startStop-1] util.Shell
> (Shell.java:getWinUtilsPath(303)) - Failed to locate the winutils binary in
> the hadoop binary path
> java.io.IOException: Could not locate executable null\bin\winutils.exe in
> the Hadoop binaries.
>
>
> On Mon, Oct 6, 2014 at 3:17 PM, ramkrishna vasudevan <
> ramkrishna.s.vasudevan@gmail.com> wrote:
>
> > Which version of hadoop are you using?
> > Follow this link to install your native libraries if you have not done it
> > already
> >
> >
> http://www.srccodes.com/p/article/38/build-install-configure-run-apache-hadoop-2.2.0-microsoft-windows-os
> > .
> >
> > And also ensure to these two in the class path - because when we try to
> run
> > the test cases using hadoop 2.2.0 we neeed to mention the path to find
> > these native libraries.
> >
> > -Dhadoop.home.dir="C:/hadoop/hadoop-2.4.0"
> > -Djava.library.path="C:/hadoop/hadoop-2.4.0/bin"
> >
> > Hope this helps.
> >
> > Regards
> > Ram
> >
> > On Mon, Oct 6, 2014 at 3:11 PM, jeevi tesh <jeevitesh.ms@gmail.com>
> wrote:
> >
> > > Hi,
> > > I'm using windows 7 (client) and haddop & hbase is installed on linux.
> > > Now while opening the connection to data base from kundera(ORM) which
> is
> > > running in win7 system I get following error.
> > > java.io.IOException: Could not locate executable null\bin\winutils.exe
> in
> > > the Hadoop binaries.
> > > Looks like a bug in hadoop
> > > https://issues.apache.org/jira/browse/SPARK-2356
> > > and status is unresolved.
> > > Please help me in finding workarounds
> > > thanks
> > > jeevitesh
> > >
> > > 2014-10-06 13:29:57,676 INFO  [localhost-startStop-1]
> > > persistence.EntityManagerFactoryImpl
> > > (EntityManagerFactoryImpl.java:<init>(127)) - Loading Core
> > > 2014-10-06 13:29:57,686 INFO  [localhost-startStop-1] loader.CoreLoader
> > > (CoreLoader.java:load(41)) - Loading Kundera Core Metdata ...
> > > 2014-10-06 13:29:57,690 INFO  [localhost-startStop-1]
> > > persistence.EntityManagerFactoryImpl
> > > (EntityManagerFactoryImpl.java:configurePersistenceUnit(627)) - Loading
> > > Persistence Unit MetaData For Persistence Unit(s) hbase_pu.
> > > 2014-10-06 13:29:57,693 INFO  [localhost-startStop-1]
> > > configure.PersistenceUnitConfiguration
> > > (PersistenceUnitConfiguration.java:configure(79)) - Loading Metadata
> from
> > > persistence.xml ...
> > > 2014-10-06 13:29:57,768 INFO  [localhost-startStop-1]
> > > configure.PersistenceUnitConfiguration
> > > (PersistenceUnitConfiguration.java:configure(96)) - Finishing
> persistence
> > > unit metadata configuration ...
> > > 2014-10-06 13:29:57,781 INFO  [localhost-startStop-1]
> > > configure.MetamodelConfiguration
> > > (MetamodelConfiguration.java:loadEntityMetadata(172)) - No class to
> scan
> > > for persistence unit hbase_pu. Entities will be loaded from classpath/
> > > context-path
> > > 2014-10-06 13:29:57,987 INFO  [localhost-startStop-1]
> > > configure.ClientMetadataBuilder
> > > (ClientMetadataBuilder.java:buildClientFactoryMetadata(37)) - Loading
> > > client factory for persistence unit hbase_pu
> > > 2014-10-06 13:29:57,989 INFO  [localhost-startStop-1]
> > client.ClientResolver
> > > (ClientResolver.java:instantiateClientFactory(73)) - Initializing
> client
> > > factory for: hbase_pu
> > > 2014-10-06 13:29:58,003 INFO  [localhost-startStop-1]
> > client.ClientResolver
> > > (ClientResolver.java:instantiateClientFactory(152)) - Finishing factory
> > > initialization
> > > 2014-10-06 13:29:58,003 INFO  [localhost-startStop-1]
> > > configure.SchemaConfiguration
> (SchemaConfiguration.java:configure(112)) -
> > > Configuring schema export for : hbase_pu
> > > 2014-10-06 13:29:58,547 WARN  [localhost-startStop-1]
> > util.NativeCodeLoader
> > > (NativeCodeLoader.java:<clinit>(62)) - Unable to load native-hadoop
> > library
> > > for your platform... using builtin-java classes where applicable
> > > 2014-10-06 13:29:58,612 ERROR [localhost-startStop-1] util.Shell
> > > (Shell.java:getWinUtilsPath(303)) - Failed to locate the winutils
> binary
> > in
> > > the hadoop binary path
> > > java.io.IOException: Could not locate executable null\bin\winutils.exe
> in
> > > the Hadoop binaries.
> > > at org.apache.hadoop.util.Shell.getQualifiedBinPath(Shell.java:278)
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message