hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: HBase code coverage
Date Tue, 21 Oct 2014 01:39:49 GMT
The following JIRA introduced  jacoco code coverage report:
https://issues.apache.org/jira/browse/HBASE-12208

Can you use that ?

Cheers

On Mon, Oct 20, 2014 at 5:30 PM, 肖春君 <chunjun.xiao@hotmail.com> wrote:

> Hi Everyone,
>
> I'm trying to get the hbase UT code coverage report, using the built-in
> clover configuration, with the following mvn command:
>     mvn clean test -fn -PrunLargeTests,hadoop-2.0,clover
> -Dzookeeper.version=3.4.5 -Dhadoop-two.version=2.4.1
>     mvn clover2:aggregate clover2:clover -Pclover
>
> HBase version: 0.98.5
> No change is made to the POM file or source code.
>
> Unfortunately, the build always fails, as shown by the following log.
> I'm not sure if it's due to my improper mvn arguments or other reason.
> So could anyone help me on how to run hbase ut code coverage?
>
> [INFO] Velocimacro : allowInlineLocal = false : VMs defined inline will
> be  global in scope if allowed.
> [INFO] Velocimacro : initialization complete.
> [INFO] Velocity successfully started.
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] HBase ............................................. FAILURE [1.110s]
> [INFO] HBase - Common .................................... SKIPPED
> [INFO] HBase - Protocol .................................. SKIPPED
> [INFO] HBase - Client .................................... SKIPPED
> [INFO] HBase - Hadoop Compatibility ...................... SKIPPED
> [INFO] HBase - Hadoop Two Compatibility .................. SKIPPED
> [INFO] HBase - Prefix Tree ............................... SKIPPED
> [INFO] HBase - Server .................................... SKIPPED
> [INFO] HBase - Testing Util .............................. SKIPPED
> [INFO] HBase - Thrift .................................... SKIPPED
> [INFO] HBase - Shell ..................................... SKIPPED
> [INFO] HBase - Integration Tests ......................... SKIPPED
> [INFO] HBase - Examples .................................. SKIPPED
> [INFO] HBase - Assembly .................................. SKIPPED
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 26.648s
> [INFO] Finished at: Mon Oct 20 08:57:46 PDT 2014
> [INFO] Final Memory: 38M/1428M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> com.atlassian.maven.plugins:maven-clover2-plugin:2.6.3:clover (default-cli)
> on project hbase: An error has occurred in Clover report generation. Could
> not resolve report descriptor:
> /data/jenkins/workspace/hbase-0_98_5-UT/maven-clover2-plugin-2.6.3.jar:
> Failed to load resource as file
> [/data/jenkins/workspace/hbase-0_98_5-UT/maven-clover2-plugin-2.6.3.jar]:
> Could not find resource
> '/data/jenkins/workspace/hbase-0_98_5-UT/maven-clover2-plugin-2.6.3.jar'.
> -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> Build step 'Execute shell' marked build as failure
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message