hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maddineni Sukumar (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-12065) Import tool is not restoring multiple DeleteFamily markers of a row
Date Tue, 23 Sep 2014 12:07:33 GMT
Maddineni Sukumar created HBASE-12065:
-----------------------------------------

             Summary:  Import tool is not restoring multiple DeleteFamily markers of a row
                 Key: HBASE-12065
                 URL: https://issues.apache.org/jira/browse/HBASE-12065
             Project: HBase
          Issue Type: Bug
          Components: util
    Affects Versions: 0.98.2
            Reporter: Maddineni Sukumar
            Assignee: Maddineni Sukumar
            Priority: Minor


When a row has more than one DeleteFamily markers, Import tool is not restoring all DeleteFamily
markers. 

Scenario: Insert entries into hbase in below order

Put Row1 with Value-A
Delete Row1 with DeleteFamily Marker
Put Row1 with Value-B
Delete Row1 with DeleteFamily Marker

Using Export tool export this data and Import it into another table, you will see below entries

Delete Row1 with DeleteFamily Marker
Put Row1 with Value-B
Put Row1 with Value-A

One DeleteFamily marker is missing here... In Import tool, Importer.writeResult() method we
are batching all deletes into a single Delete request and pushing into hbase. Here we are
pushing only one delete family marker into hbase table.

I tried same with normal HTable.delete command also. 
If you pass multiple DeleteFamily markers of a row in a single Delete request to hbase then
table is maintaining only one. 

If that is the expected  behavior of hbase then we should change logic in Import tool to push
DeleteFamily markers individually one by one.








--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message