hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Misty Stanley-Jones (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-5426) How to Set Up a Pseudo-Distributed Mode for HBase
Date Thu, 10 Jul 2014 03:40:05 GMT

     [ https://issues.apache.org/jira/browse/HBASE-5426?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Misty Stanley-Jones resolved HBASE-5426.
----------------------------------------

    Resolution: Duplicate

Please reopen if you feel that this information is still relevant and not covered by HBASE-11399.

> How to Set Up a Pseudo-Distributed Mode for HBase
> -------------------------------------------------
>
>                 Key: HBASE-5426
>                 URL: https://issues.apache.org/jira/browse/HBASE-5426
>             Project: HBase
>          Issue Type: Improvement
>          Components: documentation
>    Affects Versions: 0.92.0
>         Environment: RedHat 7, Ubuntu 10
>            Reporter: Bing Li
>            Assignee: Doug Meil
>              Labels: documentation
>             Fix For: 0.92.0
>
>   Original Estimate: 48h
>  Remaining Estimate: 48h
>
> Hi, all,
> I just made a summary about the experiences to set up a pseudo-distributed mode HBase.
> 1) RedHat 9 is not suitable for running HBase and Hadoop. I don't know the reasons. Now
Ubuntu is my choice.
> 2) After the pseudo-distributed mode of HDFS is configured, it is required to configure
the hbase-env.sh and hbase-site.xml. The book, HBase the Definitive Guide, does not mentions
hbase.env.xml.
> 3) It should set up JAVA_HOME, HBASE_CLASSPATH and HBASE_MANAGES_ZK. My hbase-env.sh
is as follows.
>      export JAVA_HOME=/opt/jdk1.6.1/
>      export HBASE_CLASSPATH=/opt/hbase-0.92.0/conf
>      export HBASE_OPTS="-XX:+UseConcMarkSweepGC"
>      export HBASE_MANAGES_ZK=true
> 4) When configuring hbase-site.xml, the property, hbase.cluster.distributed, must be
set also. The book, HBase the Definitive Guide, does not do that either. My hbase-site.xml
is as follows.
>      <?xml version="1.0"?>
>      <?xml-stylesheet type="text/xsl" href="configuration.xsl"?>
>      <configuration>
>         <property>
>            <name>hbase.rootdir</name>
>            <value>hdfs://localhost:9000/hbase</value>
>         </property>
>         <property>
>            <name>dfs.replication</name>
>            <value>1</value>
>         </property>
>         <property>
>            <name>hbase.cluster.distributed</name>
>            <value>true</value>
>         </property>
>      </configuration>
> I am a new user of HBase. Your suggestions are highly appreciated.
> Best regards,
> Bing



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message