hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Demai Ni <nid...@gmail.com>
Subject Re: hadoopQA links to findbugs warning broken
Date Wed, 02 Jul 2014 22:40:47 GMT
Ted and Mikhail, many thanks for the tip. I will do it locally.... Demai


On Wed, Jul 2, 2014 at 3:33 PM, Ted Yu <yuzhihong@gmail.com> wrote:

> For the time being, target/findbugsXml.xml should be checked to see if any
> warning is for code changed by the patch.
>
> Cheers
>
>
> On Wed, Jul 2, 2014 at 1:51 PM, Mikhail Antonov <olorinbant@gmail.com>
> wrote:
>
> > I've seen the same before and followed Ted's suggestion above on how to
> see
> > findbug warnings.
> >
> > Though unless I'm missing something, running maven findbugs:findbugs
> > command will show all warnings for the module, not specifically the ones
> > which appear to be introduced by the patch being tested. Would be nice to
> > have the link to the concise list of warnings related to patch.
> >
> > Also, seems like test reporting is somewhat messed up?
> > https://builds.apache.org/job/PreCommit-HBASE-Build/9940//testReport/ -
> > this link redirects to
> > https://builds.apache.org/job/PreCommit-HBASE-Build/9940// and it
> doesn't
> > show failed tests report, right?
> >
> > -Mikhail
> >
> >
> > 2014-07-02 13:23 GMT-07:00 Ted Yu <yuzhihong@gmail.com>:
> >
> > > You can execute the following command locally:
> > > mvn clean package findbugs:findbugs
> > >
> > > then you would be able to check target/findbugsXml.xml under respective
> > > module.
> > >
> > > Cheers
> > >
> > >
> > > On Wed, Jul 2, 2014 at 1:16 PM, Demai Ni <nidmgg@gmail.com> wrote:
> > >
> > > > hi, folks,
> > > >
> > > > I encountered this problem a couple times already. Basically,
> hadoopQA
> > > > cames back with complain about "-1 findbugs. ..", then I tried to
> > > following
> > > > the links in the hadoopQA report to diag, but none of the findbugs
> > links
> > > > works. The latest example is here: for hbase-9531
> > > >
> > > >
> > >
> >
> https://issues.apache.org/jira/browse/HBASE-9531?focusedCommentId=14050589&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14050589
> > > > .
> > > >
> > > >
> > > > I don't think I am the only 'luck' one. :-) Any clue on that? thanks
> a
> > > lot
> > > >
> > > > Demai
> > > >
> > >
> >
> >
> >
> > --
> > Thanks,
> > Michael Antonov
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message