hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: How to validate HBase configuration (for region servers) from HBase admin page?
Date Mon, 28 Jul 2014 19:23:13 GMT
And don't forget to set -XX:MaxDirectMemorySize (from 9.6.4.5.1. Enable
SlabCache in the refguide -- http://hbase.apache.org/book.html).  This you
set where you pass your server JVM args.

St.Ack


On Mon, Jul 28, 2014 at 12:21 PM, Stack <stack@duboce.net> wrote:

> Probably a question for the cloudera hbase list?  (Did you enter the block
> cache configs via CM safety valve mechanism?)
> Yours,
> St.Ack
>
>
> On Mon, Jul 28, 2014 at 11:54 AM, Gabriela Montiel <
> gabriela.montiel@oracle.com> wrote:
>
>>
>> Hi Shengzhe,
>>
>> We executed a rolling restart on HBase through Cloudera 5, but after
>> completing the site retrieved the same configurations.
>>
>> Thanks,
>>
>> Gaby
>>
>> Sent from my Samsung Mobile
>>
>>
>> -------- Original message --------
>> From: yao <yaoshengzhe@gmail.com>
>> Date:28/07/2014  13:43  (GMT-06:00)
>> To: dev@hbase.apache.org
>> Subject: Re: How to validate HBase configuration (for region servers)
>> from HBase admin page?
>>
>> Hi Gaby,
>>
>> Did you restart your regionservers ? If not, HBase won't pick up the
>> up-to-date configuration.
>>
>> Best
>> Shengzhe
>>
>>
>>
>>
>> On Mon, Jul 28, 2014 at 11:38 AM, Ted Yu <yuzhihong@gmail.com> wrote:
>>
>> > bq. <source>hbase-site.xml</source>
>> >
>> > Can you check the hbase-site.xml which is in classpath of the region
>> server
>> > ?
>> >
>> > What release of hbase are you using ?
>> >
>> > Cheers
>> >
>> >
>> > On Mon, Jul 28, 2014 at 11:28 AM, gabriela montiel <
>> > gabriela.montiel@oracle.com> wrote:
>> >
>> > > Hi all,
>> > >
>> > > We have set up an HBase cluster with 10 region nodes. We modified the
>> > > default configurations to handle bucket cache in the hbase-site.xml
>> (for
>> > > all region servers) as follows:
>> > >
>> > >   <property>
>> > >     <name>hbase.regionserver.handler.count</name>
>> > >     <value>40</value>
>> > >   </property>
>> > >   <property>
>> > >     <name>hbase.bucketcache.ioengine</name>
>> > >     <value>offheap</value>
>> > >   </property>
>> > >   <property>
>> > > <name>hbase.bucketcache.percentage.in.combinedcache</name>
>> > >     <value>0.8</value>
>> > >   </property>
>> > >   <property>
>> > >     <name>hbase.bucketcache.size</name>
>> > >     <value>40000</value>
>> > >   </property>
>> > >
>> > > However, when we access the HBase configuration page on the HBase Web
>> > > admin, we are not able to see the updated configurations, even for the
>> > ones
>> > > not related to bucket cache:
>> > >
>> > > <property><name>hbase.regionserver.handler.count</
>> > > name><value>*30*</value><source>hbase-site.xml</source></property>
>> > >
>> > >
>> > > Can you give us a hint on why the configurations are not seen in the
>> > HBase
>> > > configuration site, and how we can check out the HBase configuration
>> for
>> > > all region servers?
>> > >
>> > > Thanks,
>> > >
>> > > Gaby
>> > >
>> > >
>> > >
>> > >
>> > >
>> > >
>> > >
>> > >
>> > >
>> > >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message