hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Misty Stanley-Jones (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-9729) mvn site fails without install first
Date Wed, 28 May 2014 01:02:01 GMT

     [ https://issues.apache.org/jira/browse/HBASE-9729?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Misty Stanley-Jones resolved HBASE-9729.
----------------------------------------

    Resolution: Cannot Reproduce
      Assignee: Misty Stanley-Jones

I can't reproduce this and think it must have been fixed long ago.

> mvn site fails without install first
> ------------------------------------
>
>                 Key: HBASE-9729
>                 URL: https://issues.apache.org/jira/browse/HBASE-9729
>             Project: HBase
>          Issue Type: Bug
>          Components: build, documentation
>            Reporter: Enis Soztutar
>            Assignee: Misty Stanley-Jones
>         Attachments: HBASE-9729-0.patch
>
>
> mvn site fails on hadoopqa runs, and also on fresh checkouts. The problem seems to be
that mvn site somehow does not trigger a correct reactor ordering. hbase-server is built before
other components, and thus throws dependency errors because the other modules are not build
yet. 
> An example from https://builds.apache.org/job/PreCommit-HBASE-Build/7491//consoleFull:

> {code}
> /home/jenkins/tools/maven/latest/bin/mvn compile site -DskipTests -DHBasePatchProcess
> /home/jenkins/jenkins-slave/workspace/PreCommit-HBASE-Build/patchprocess/patchSiteOutput.txt
2>&1
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message