hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-5601) Add per-column-family data block cache hit ratios
Date Wed, 21 May 2014 20:38:39 GMT

     [ https://issues.apache.org/jira/browse/HBASE-5601?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

stack resolved HBASE-5601.

    Resolution: Won't Fix

Resolving as won't fix for trunk at least (may be in 0.89fb).  The items raised by Enis in
the description are no longer apt given per-cf metrics were removed by HBASE-6410 (in 0.96)
-- too expensive to calculate.

That said, let me respond to the original list since much of it still has merit and I am trying
to address in our new per-1.0 context.

bq. Make Per-cf and global block cache metrics naming consistent (hbase.regionserver.blockCacheHitCount
vs hbase.RegionServerDynamicStatistics.tbl.usertable.cf.ycsb.bt.Data.fsBlockReadCacheHitCnt)

This change looks done though rather than hbase.regionserver.blockCacheHitCount  we have hbase.regionserver.server.blockCacheHitCount
(The mbean that hosts this metric is hbase.regionserver.server).

All blockcache metrics have a blockCache prefix in hadoop metrics2 (except 'blockCountHitPercent'
which I'll fix).

bq. Rename hbase.RegionServerDynamicStatistics.XXX -> hbase.regionserver.dyn.XXX
Rename dynamic metric names tbl.usertable.cf.ycsb.bt.Data.fsBlockReadCacheHitCnt -> tbl=usertable.cf=ycsb.bt=Data.at=scan.BlockCacheHitCount.
Here at stands for access type, and can be scan or compaction.
For at=compaction, we probably do not need per-block type (Data, Index, ...) metric values,
shall we aggregate them?

Not pertinent to trunk.

bq. Shall we extend per-cf metrics into HBASE-5533 (read/write latency histograms)?

Not pertinent anymore.

bq. With slab cache, we may no longer have one global block cache. Shall we enable per-cache
type metrics? This can imply renaming hbase.regionserver.blockCache => hbase.regionserver.lrublockcache,
slabblockcache, etc.

We need this. Will file an issue.

bq. Add a configuration for disabling per-cf metrics.

No longer pertinent since removal.

> Add per-column-family data block cache hit ratios
> -------------------------------------------------
>                 Key: HBASE-5601
>                 URL: https://issues.apache.org/jira/browse/HBASE-5601
>             Project: HBase
>          Issue Type: Improvement
>          Components: metrics, monitoring
>            Reporter: Mikhail Bautin
>            Assignee: Enis Soztutar
> In addition to the overall block cache hit ratio it would be extremely useful to have
per-column-family data block cache hit ratio metrics.

This message was sent by Atlassian JIRA

View raw message