hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Demai Ni <nid...@gmail.com>
Subject Re: jetty 9 on hbase? (HADOOP-10075)
Date Sun, 18 May 2014 16:22:53 GMT
hi, Andrew,

If I understand you correctly, we have to do the Jetty 9 upgrade after
HADOOP-10075 integrated, and when we officially upgrade hbase dependency of
the new version of Hadoop, right?

Demai


On Sun, May 18, 2014 at 12:33 AM, Andrew Purtell <apurtell@apache.org>wrote:

> Except such a JIRA won't be actionable. We can't upgrade our jetty
> dependency if it's going to conflict with what Hadoop uses and brings in
> transitively.
>
> On Sunday, May 18, 2014, Demai Ni <nidmgg@gmail.com> wrote:
>
> > Sounds good. I will open one if I can make it works on 96.x.
> >
> > Currently my change on Infoserver seems ok.  RESTserver compiled, but I
> > can start rest. Need to play more tomorrow
> >
> > Demai on the run
> >
> > On May 16, 2014, at 9:34 PM, Ted Yu <yuzhihong@gmail.com <javascript:;>>
> > wrote:
> >
> > > You may want to open a JIRA with your findings.
> > >
> > > Cheers
> > >
> > >
> > > On Fri, May 16, 2014 at 7:49 PM, Demai Ni <nidmgg@gmail.com
> <javascript:;>>
> > wrote:
> > >
> > >> Ted,
> > >>
> > >> Thanks. I am changing the poms (both top and the one under Hbase-
> > server).
> > >> Due to the incompatible btw jetty 6 and 9, infoserver and RESTserver
> > need
> > >> code changes too. Well, something to play with this weekend.
> > >>
> > >> Demai on the run
> > >>
> > >> On May 16, 2014, at 4:11 PM, Ted Yu <yuzhihong@gmail.com<javascript:;>>
> > wrote:
> > >>
> > >>> HADOOP-10075 is not integrated yet.
> > >>> It doesn't have Fix Version(s) either.
> > >>>
> > >>> For HBase, you can change the version strings in pom.xml to match the
> > >> ones
> > >>> from your hadoop build :
> > >>>   <jetty.version>6.1.26</jetty.version>
> > >>>   <jetty.jspapi.version>6.1.14</jetty.jspapi.version>
> > >>>
> > >>> Cheers
> > >>>
> > >>>
> > >>> On Fri, May 16, 2014 at 2:49 PM, Demai Ni <nidmgg@gmail.com
> <javascript:;>>
> > wrote:
> > >>>
> > >>>> hi, folks,
> > >>>>
> > >>>> wondering anyone already began to use Jetty 9 with HBase. We are
> > trying
> > >> to
> > >>>> use Jetty9 in hadoop, and got the following exceptions when start
> > HBase:
> > >>>> ...
> > >>>> java.lang.ClassCastException:
> > >>>> org.eclipse.jetty.servlet.ServletContextHandler incompatible with
> > >>>> org.mortbay.jetty.servlet.Context
> > >>>>       at
> > >>
> >
> org.apache.hadoop.hbase.util.InfoServer.fixupLogsServletLocation(InfoServer.java:74)
> > >>>> ...
> > >>>>
> > >>>> caused by the mis-match of Jetty9 and Jetty6(current HBase
> > dependency).
> > >>>>
> > >>>> On hadoop side HADOOP-10075 is pending. I am thinking about changing
> > >> hbase
> > >>>> code(0.96) to bypass the problem.
> > >>>>
> > >>>> Many thanks.
> > >>>>
> > >>>> Demai
> > >>
> >
>
>
> --
> Best regards,
>
>    - Andy
>
> Problems worthy of attack prove their worth by hitting back. - Piet Hein
> (via Tom White)
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message