hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Liu Shaohui (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-10617) Value lost if "$" element is before "column" element in json when posted to Rest Server
Date Wed, 26 Feb 2014 10:05:20 GMT
Liu Shaohui created HBASE-10617:
-----------------------------------

             Summary: Value lost if "$" element is before "column" element in json when posted
to Rest Server
                 Key: HBASE-10617
                 URL: https://issues.apache.org/jira/browse/HBASE-10617
             Project: HBase
          Issue Type: Bug
          Components: REST
    Affects Versions: 0.94.11
            Reporter: Liu Shaohui
            Priority: Minor


When post following json data to rest server, it return 200, but the value is null in HBase
{code}
{"Row": { "key":"cjI=", "Cell": {"$":"ZGF0YTE=", "column":"ZjE6YzI="}}}
{code}

>From rest server log, we found the length of value is null after the server paste the
json to RowModel object
{code}
14/02/26 17:52:14 DEBUG rest.RowResource: PUT {"totalColumns":1,"families":{"f1":[{"timestamp":9223372036854775807,"qualifier":"c2","vlen":0}]},"row":"r2"}
{code}

When the order is that "column" before "$",  it works fine.
{code}
{"Row": { "key":"cjI=", "Cell": {"column":"ZjE6YzI=", "$":"ZGF0YTE=" }}}
{code}

DIfferent json libs may have different order of this two elements even if "column" is put
before "$".





--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message