hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Feng Honghua (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-10564) HRegionServer.nextLong should be removed since it's not used anywahre, or should be used somewhere it meant to
Date Tue, 18 Feb 2014 08:24:19 GMT
Feng Honghua created HBASE-10564:
------------------------------------

             Summary: HRegionServer.nextLong should be removed since it's not used anywahre,
or should be used somewhere it meant to
                 Key: HBASE-10564
                 URL: https://issues.apache.org/jira/browse/HBASE-10564
             Project: HBase
          Issue Type: Bug
          Components: regionserver
            Reporter: Feng Honghua
            Assignee: Feng Honghua
            Priority: Minor


HRegionServer has its own nextLong method as below:
{code}
  /**
   * Generate a random positive long number
   *
   * @return a random positive long number
   */
  protected long nextLong() {
    long n = rand.nextLong();
    if (n == 0) {
      return nextLong();
    }
    if (n < 0) {
      n = -n;
    }
    return n;
  }
{code}

# It's never called anywhere, if we can ensure it's really useless, it should be removed
# Looks likely below should use *nextLong* rather than *rand.nextLong*(but not sure):
{code}
  protected long addScanner(RegionScanner s, HRegion r) throws LeaseStillHeldException {
    long scannerId = -1;
    while (true) {
      scannerId = Math.abs(rand.nextLong() << 24) ^ startcode;
      String scannerName = String.valueOf(scannerId);
      RegionScannerHolder existing =
        scanners.putIfAbsent(scannerName, new RegionScannerHolder(s, r));
      if (existing == null) {
        this.leases.createLease(scannerName, this.scannerLeaseTimeoutPeriod,
          new ScannerListener(scannerName));
        break;
      }
    }
    return scannerId;
  }
{code}
# Its implemenation would be better if
{code}
    if (n == 0) {
      return nextLong();
    }
{code}
is changed to below (with better readability and (possible) less call-stacks by removing recursion)
{code}
    while (n == 0) {
      n = rand.nextLong();
    }
{code}



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message