hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Liochon <nkey...@gmail.com>
Subject Re: 1.5.0-SNAPSHOT conflicting with hbase-proto 0.96.x
Date Tue, 28 Jan 2014 17:12:27 GMT
Hum.... the API is different today, and will remain different after

has:  public static ByteString wrap(final byte[] array, int offset, int
length) {

And this method is not in

It's too brittle. I created HBASE-10431 for this.

On Mon, Jan 27, 2014 at 5:35 PM, tsuna <tsunanet@gmail.com> wrote:

> On Mon, Jan 27, 2014 at 1:02 AM, Nicolas Liochon <nkeywal@gmail.com>
> wrote:
> > Should we not rename ZeroCopyLiteralByteString to something like
> > HBasePrivateZeroCopyLiteralByteString to be sure that we won't have name
> > conflicts in the future?
> I don't mind keeping the same name as long as we agree on the API.
> I don't expect this class to change much if at all anyway.  It's just
> really unfortunate that this method was changed, what's more with a
> signature that renders it unusable.
> --
> Benoit "tsuna" Sigoure

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message