hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Compiling with hadoop 2.0 and hadoop 3.0
Date Mon, 23 Dec 2013 16:34:31 GMT
Ram:
Did you refer to compiling against hadoop 2.0 ?
I got same error when specifying -Dhadoop.profile=2.0

But this shouldn't be a blocker for you - hadoop2 is the default profile.

Cheers


On Mon, Dec 23, 2013 at 8:28 AM, ramkrishna vasudevan <
ramkrishna.s.vasudevan@gmail.com> wrote:

> Are you able to compile it Ted?  I tried once again, am not able to compile
> it.  May be i should clean the maven repo and again try.
>
>
>
> On Mon, Dec 23, 2013 at 7:36 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>
> > For compiling against Hadoop 3, there is HBASE-6581 which is in progress.
> >
> > Hadoop 2 is the default profile for trunk.
> >
> > Cheers
> >
> > On Dec 23, 2013, at 2:36 AM, ramkrishna vasudevan <
> > ramkrishna.s.vasudevan@gmail.com> wrote:
> >
> > > Trying to execute
> > > mvn clean install -DskipTests -Dhadoop.profile=2.0
> > > mvn clean install -DskipTests -Dhadoop.profile=3.0
> > > I get the following error
> > >
> > > [ERROR]   The project org.apache.hbase:hbase:0.99.0-SNAPSHOT
> > > (/home/ram/hbase_test/trunk/pom.xml) has 2 errors
> > > [ERROR]     'dependencyManagement.dependencies.dependency.artifactId'
> for
> > > org.apache.hbase:${compat.module}:jar with value '${compat.module}'
> does
> > > not match a valid id pattern. @ line 1005, column 21
> > > [ERROR]     'dependencyManagement.dependencies.dependency.artifactId'
> for
> > > org.apache.hbase:${compat.module}:test-jar with value
> '${compat.module}'
> > > does not match a valid id pattern. @ line 1010, column 21
> > >
> > > Running with
> > > mvn clean install -DskipTests -Dhadoop.profile=1.0 and without
> > > hadoop.profile makes it work.
> > >
> > > Regards
> > > Ram
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message