hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject NullPointerException building HBase assembly
Date Tue, 08 Oct 2013 20:16:07 GMT
Hi,
Under 0.96 workspace, I issued the following commands:

 ./dev-support/generate-hadoopX-poms.sh 0.96.0 0.96.0-hadoop2
 mvn clean install -DskipTests -f pom.xml.hadoop2
 mvn install assembly:single -f pom.xml.hadoop2 -DskipTests
-Dmaven.javadoc.skip=true -Dhadoop.profile=2.0 -X

I got the following:


[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-assembly-plugin:2.4:single (default-cli) on
project hbase-assembly: Execution default-cli of goal
org.apache.maven.plugins:maven-assembly-plugin:2.4:single failed.
NullPointerException -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
goal org.apache.maven.plugins:maven-assembly-plugin:2.4:single
(default-cli) on project hbase-assembly: Execution default-cli of goal
org.apache.maven.plugins:maven-assembly-plugin:2.4:single failed.
  at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:225)
  at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
  at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
  at
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
  at
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
  at
org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
  at
org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
  at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
  at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
  at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
  at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
  at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
  at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
  at java.lang.reflect.Method.invoke(Method.java:606)
  at
org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
  at
org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
  at
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
  at
org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
Caused by: org.apache.maven.plugin.PluginExecutionException: Execution
default-cli of goal
org.apache.maven.plugins:maven-assembly-plugin:2.4:single failed.
  at
org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:110)
  at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
  ... 19 more
Caused by: java.lang.NullPointerException
  at java.io.File.<init>(File.java:334)
  at
org.apache.maven.plugin.assembly.io.RelativeFileLocatorStrategy.resolve(RelativeFileLocatorStrategy.java:45)
  at org.apache.maven.shared.io.location.Locator.resolve(Locator.java:81)
  at
org.apache.maven.plugin.assembly.io.DefaultAssemblyReader.addAssemblyFromDescriptor(DefaultAssemblyReader.java:298)
  at
org.apache.maven.plugin.assembly.io.DefaultAssemblyReader.readAssemblies(DefaultAssemblyReader.java:120)
  at
org.apache.maven.plugin.assembly.mojos.AbstractAssemblyMojo.execute(AbstractAssemblyMojo.java:401)
  at
org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
  ... 20 more

Was any of the command wrong ?

Cheers

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message