hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Marc Spaggiari <jean-m...@spaggiari.org>
Subject Re: [VOTE] The 1st hbase-0.96.0 release candidate is available for download
Date Mon, 02 Sep 2013 16:41:50 GMT
Got it.

I can't run the integration tests for now because I'm lacking some
servers :( Need to complete some HBase on RAID tests before I can get
those new servers

First thing is, start-hbase.cmd has the execute flag set. I don't
think it's required. And it will help with tabulation feature if we
can un-set it.

For 0.96.0RC0 here are my results:
First, I get 2 .out files. each time I start the server, instead of
usually one... With the same timestamp.

-rw-r--r-- 1 jmspaggiari jmspaggiari     0 Aug 31 15:38
-rw-r--r-- 1 jmspaggiari jmspaggiari     0 Aug 31 15:38

In the UI, we say "The .META. table holds references to all User Table
regions" but the table name is "hbase:meta" and not ".META."

On the logs, I found this exception that I did not had before:
2013-08-31 18:45:05,490 WARN
[NIOServerCxn.Factory:] server.NIOServerCnxn:
caught end of stream exception
EndOfStreamException: Unable to read additional data from client
sessionid 0x140d68bb9d50004, likely client has closed socket
    at org.apache.zookeeper.server.NIOServerCnxn.doIO(NIOServerCnxn.java:220)
    at org.apache.zookeeper.server.NIOServerCnxnFactory.run(NIOServerCnxnFactory.java:208)
    at java.lang.Thread.run(Thread.java:662)

I ran PE over 48h. I don't have another 0.96 baseline to compare with,
so I compared with 0.94.
org.apache.hadoop.hbase.PerformanceEvaluation$RandomSeekScanTest is
about 3 times slower with 0.96.
seems to be 2 times faster.

Writes also are faster but I changed my hard drive since I ran 0.94.
So I'm currently re-running 0.94 and will provide another more
accurate comparison soon.

Ran LoadTestTool: Failed to write keys: 0

I have not been able to run IntegrationTestLoadAndVerify nor
IntegrationTestBigLinkedList because of the lack of servers.

So overall, it seems to be working fine, but I have not been able to
test this release as deeply as I'm usually testing the 0.94 releases.


View raw message