hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Latham (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-1913) Regionserver accepts connections, doesn't handle them after bad filter request
Date Mon, 19 Aug 2013 22:47:47 GMT

     [ https://issues.apache.org/jira/browse/HBASE-1913?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dave Latham resolved HBASE-1913.
--------------------------------

    Resolution: Duplicate

Resolved by HBASE-3939
                
> Regionserver accepts connections, doesn't handle them after bad filter request
> ------------------------------------------------------------------------------
>
>                 Key: HBASE-1913
>                 URL: https://issues.apache.org/jira/browse/HBASE-1913
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.19.3, 0.20.1
>         Environment: Observed on HBase 0.19 HEAD
>            Reporter: Dave Latham
>
> I deployed some new regionservers but forgot to include a library that one of my filters
used.  When a client used that filter, the HBaseServer listener thread attempted to deserialize
it, and threw a NoClassDefFoundError.  This killed the listener thread without cleaning up
the socket (only Exception and OOME are caught, not other Error subclasses).  New clients
continued to successfully open TCP connections, but the regionserver would never handle them,
never shutdown, and the master would never expire it, so all of its regions were effectively
unavailable until we intervened.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message