hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Czerwiński (JIRA) <j...@apache.org>
Subject [jira] [Created] (HBASE-8793) Hbase
Date Mon, 24 Jun 2013 10:08:21 GMT
Michael Czerwiński created HBASE-8793:
-----------------------------------------

             Summary: Hbase 
                 Key: HBASE-8793
                 URL: https://issues.apache.org/jira/browse/HBASE-8793
             Project: HBase
          Issue Type: Bug
          Components: scripts
    Affects Versions: 0.94.6
         Environment: Description:    Ubuntu 12.04.2 LTS
Hbase: 0.94.6+96-1.cdh4.3.0.p0.13~precise-cdh4.3.0
            Reporter: Michael Czerwiński
            Priority: Minor


hbase-regionserver startup script always returns 0 (exit 0 at the end of the script) this
is wrong behaviour which causes issues when trying to recognise true status of the service.
Replacing it with 'exit $?' seems to fix the problem, looking at hbase master return codes
are assigned to RETVAL variable which is used with exit.

Not sure if the problem exist in other versions.

> /etc/init.d/hbase-regionserver.orig status
hbase-regionserver is not running.
> echo $?

After fix:

> /etc/init.d/hbase-regionserver status
hbase-regionserver is not running.
> echo $?
1


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message