hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: unable to run unit test in trunk against hadoop 2.0
Date Wed, 10 Apr 2013 21:52:23 GMT
Andy commented on HBASE-8165, confirming that the test failures were due to
incompatibilities between protobuf (2.5.0) HBase uses and the version (2.4)
that hadoop 2.0 uses.

On Wed, Apr 10, 2013 at 2:49 PM, Jonathan Hsieh <jon@cloudera.com> wrote:

> From this [1] build, it looks like one of these two introduced the problem
> -- :
>
>    1. HBASE-8266-Master cannot start if TableNotFoundException is thrown
>    while partial table recovery(Ram)
> (detail<
> http://54.241.6.143/job/HBase-TRUNK-Hadoop-2/org.apache.hbase$hbase-server/106/changes#detail0
> >
>    )
>    2. HBASE-8165 Update our protobuf to 2.5 from 2.4.1
> (detail<
> http://54.241.6.143/job/HBase-TRUNK-Hadoop-2/org.apache.hbase$hbase-server/106/changes#detail1
> >
>    )
>
>
> Spent a minute to look at the errors, it looks like all of them are related
> to protobuf -- looks like HBASE-8165 is the trigger.  Have you tried doing
> a 'mvn instal' to upated the hbase-protocol module to see if that fixed the
> problem?
>
> [1]
>
> http://54.241.6.143/job/HBase-TRUNK-Hadoop-2/org.apache.hbase$hbase-server/106/#showFailuresLink
>
> On Wed, Apr 10, 2013 at 2:40 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>
> > Jon:
> > Looks like your workspace was out of date.
> >
> > Have you seen this (204 test failures) ?
> >
> > http://54.241.6.143/job/HBase-TRUNK-Hadoop-2/107/testReport/
> >
> > On Wed, Apr 10, 2013 at 2:37 PM, Jonathan Hsieh <jon@cloudera.com>
> wrote:
> >
> > > Hey Ted,
> > >
> > > I was working on fixing that particular unit test against hadoop2 this
> > > morning in HBASE-7606 and it seems to work for me (after the patch.
> > Before
> > > the patch it tends to hang).  Are you running it like this:
> > >
> > > $ mvn clean test -Dhadoop.profile=2.0 -Dtest=TestJoinedScanners
> > > ....
> > > -------------------------------------------------------
> > >  T E S T S
> > > -------------------------------------------------------
> > > Running org.apache.hadoop.hbase.regionserver.TestJoinedScanners
> > > Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 63.813
> > sec
> > >
> > >
> > > Jon.
> > >
> > >
> > > On Wed, Apr 10, 2013 at 2:01 PM, Ted Yu <yuzhihong@gmail.com> wrote:
> > >
> > > > Hi,
> > > > I am getting the following error when trying to run unit test in
> trunk
> > > > against hadoop 2.0:
> > > >
> > > >
> > >
> >
> testJoinedScanners(org.apache.hadoop.hbase.regionserver.TestJoinedScanners)
> > > >  Time elapsed: 2.518 sec  <<< ERROR!
> > > > java.lang.UnsupportedOperationException: This is supposed to be
> > > overridden
> > > > by subclasses.
> > > >   at
> > > >
> > > >
> > >
> >
> com.google.protobuf.GeneratedMessage.getUnknownFields(GeneratedMessage.java:180)
> > > >   at
> > > >
> > > >
> > >
> >
> org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$GetDatanodeReportRequestProto.getSerializedSize(ClientNamenodeProtocolProtos.java:21566)
> > > >   at
> > > >
> > > >
> > >
> >
> com.google.protobuf.AbstractMessageLite.toByteString(AbstractMessageLite.java:49)
> > > >   at
> > > >
> > > >
> > >
> >
> org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.constructRpcRequest(ProtobufRpcEngine.java:149)
> > > >   at
> > > >
> > > >
> > >
> >
> org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:193)
> > > >
> > > > Looks like the above only happens with hadoop 2.0, not hadoop 1.0
> > > >
> > > > FYI
> > > >
> > >
> > >
> > >
> > > --
> > > // Jonathan Hsieh (shay)
> > > // Software Engineer, Cloudera
> > > // jon@cloudera.com
> > >
> >
>
>
>
> --
> // Jonathan Hsieh (shay)
> // Software Engineer, Cloudera
> // jon@cloudera.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message