hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Hsieh <...@cloudera.com>
Subject Re: Compile does not work against Hadoop-1.0.0 - 1.0.2
Date Fri, 26 Apr 2013 14:10:34 GMT
great, lgtm!


On Thu, Apr 25, 2013 at 9:11 PM, Stack <stack@duboce.net> wrote:

> Did as you suggest Jon in https://issues.apache.org/jira/browse/HBASE-8444
> St.Ack
>
>
> On Thu, Apr 25, 2013 at 5:21 PM, Jonathan Hsieh <jon@cloudera.com> wrote:
>
> > Want to add 1.0.3 and keep a 1.0.0-1.0.2 lines as is (if they are valid).
> >  might want to rename 0.96 to 0.95 and possibly add a trunk column?
> >
> >
> > On Thu, Apr 25, 2013 at 4:59 PM, Stack <stack@duboce.net> wrote:
> >
> > > Doc'ing it seems good to me.  Here is a suggested change (if good, i'll
> > > commit against an issue so we have a note of what Enis found):
> > >
> > >
> > >
> > > durruti:trunk stack$ svn diff --force src/main/docbkx/
> > > Index: src/main/docbkx/configuration.xml
> > > ===================================================================
> > > --- src/main/docbkx/configuration.xml (revision 1475995)
> > > +++ src/main/docbkx/configuration.xml (working copy)
> > > @@ -231,7 +231,7 @@
> > >       </thead><tbody>
> > >           <row><entry>Hadoop-0.20.205</entry><entry>S</entry>
> > >  <entry>X</entry>           <entry>X</entry></row>
> > >           <row><entry>Hadoop-0.22.x  </entry><entry>S</entry>
> > >  <entry>X</entry>           <entry>X</entry></row>
> > > -         <row><entry>Hadoop-1.0.x   </entry><entry>S</entry>
> > >  <entry>S</entry>           <entry>S</entry></row>
> > > +         <row><entry>Hadoop-1.0.3+<footnote><para>HBase
requires
> hadoop
> > > 1.0.3 at a minimum; there is an issue where we cannot find KerberosUtil
> > > compiling against earlier versions of Hadoop.</para></footnote>
> > > </entry><entry>S</entry>          <entry>S</entry>
> > > <entry>S</entry></row>
> > >           <row><entry>Hadoop-1.1.x   </entry><entry>NT</entry>
> > > <entry>S</entry>           <entry>S</entry></row>
> > >           <row><entry>Hadoop-0.23.x  </entry><entry>X</entry>
> > >  <entry>S</entry>           <entry>NT</entry></row>
> > >           <row><entry>Hadoop-2.x     </entry><entry>X</entry>
> > >  <entry>S</entry>           <entry>S</entry></row>
> > >
> > >
> > >
> > >
> > >
> > > On Thu, Apr 25, 2013 at 11:31 AM, Enis Söztutar <enis.soz@gmail.com>
> > > wrote:
> > >
> > > > No, not that I know of.
> > > >
> > > > That's why I suggested that one option to dealing with this issue is
> to
> > > > just document this case, and move on.
> > > >
> > > > Enis
> > > >
> > > >
> > > > On Thu, Apr 25, 2013 at 11:28 AM, Andrew Purtell <
> apurtell@apache.org
> > > > >wrote:
> > > >
> > > > > Sure. That's the question I have too: Is there anything about 1.0.3
> > or
> > > > > later which would be an incompatibility with 1.0.0 - 1.0.2 or
> > prevent a
> > > > > rolling upgrade?
> > > > >
> > > > >
> > > > > On Thu, Apr 25, 2013 at 11:22 AM, Enis Söztutar <
> enis.soz@gmail.com>
> > > > > wrote:
> > > > >
> > > > > > The only reason I see is that you might be stuck with an older
> > > version
> > > > of
> > > > > > Hadoop for some other reason.
> > > > > >
> > > > > > Enis
> > > > > >
> > > > > >
> > > > > > On Thu, Apr 25, 2013 at 11:13 AM, Andrew Purtell <
> > > apurtell@apache.org
> > > > > > >wrote:
> > > > > >
> > > > > > > Is there a valid reason for using a Hadoop version older
than
> > 1.0.3
> > > > if
> > > > > > > compiling up your own deploy?
> > > > > > >
> > > > > > >
> > > > > > > On Wed, Apr 24, 2013 at 6:29 PM, Enis Söztutar <
> > enis.soz@gmail.com
> > > >
> > > > > > wrote:
> > > > > > >
> > > > > > > > While trying with older Hadoop versions, I noticed
that we do
> > not
> > > > > > compile
> > > > > > > > against hadoop versions older than 1.0.3.
> > > > > > > >
> > > > > > > > I think the programmatic kerberos jaas configuration
broke
> the
> > > > > compat:
> > > > > > > > The error is:
> > > > > > > >
> > > > > > > > [ERROR]
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> /Users/enis/projects/hbase/hbase-client/src/main/java/org/apache/hadoop/hbase/zookeeper/ZKUtil.java:[36,53]
> > > > > > > > cannot find symbol
> > > > > > > > symbol  : class KerberosUtil
> > > > > > > > location: package
> > org.apache.hadoop.security.authentication.util
> > > > > > > > [ERROR]
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> /Users/enis/projects/hbase/hbase-client/src/main/java/org/apache/hadoop/hbase/zookeeper/ZKUtil.java:[247,32]
> > > > > > > > cannot find symbol
> > > > > > > > symbol  : variable KerberosUtil
> > > > > > > > location: class
> > > > > > > org.apache.hadoop.hbase.zookeeper.ZKUtil.JaasConfiguration
> > > > > > > >
> > > > > > > >
> > > > > > > > Should we fix this, or just document the case, and
not work
> > with
> > > > > older
> > > > > > > > hadoop versions than 1.0.3
> > > > > > > >
> > > > > > > > Enis
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Best regards,
> > > > > > >
> > > > > > >    - Andy
> > > > > > >
> > > > > > > Problems worthy of attack prove their worth by hitting
back. -
> > Piet
> > > > > Hein
> > > > > > > (via Tom White)
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Best regards,
> > > > >
> > > > >    - Andy
> > > > >
> > > > > Problems worthy of attack prove their worth by hitting back. - Piet
> > > Hein
> > > > > (via Tom White)
> > > > >
> > > >
> > >
> >
> >
> >
> > --
> > // Jonathan Hsieh (shay)
> > // Software Engineer, Cloudera
> > // jon@cloudera.com
> >
>



-- 
// Jonathan Hsieh (shay)
// Software Engineer, Cloudera
// jon@cloudera.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message