hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Build failing in Hbase branch 0.95
Date Fri, 08 Mar 2013 02:50:48 GMT
/home/shivends/.m2/settings.**xml

I don't have such file under my ~/.m2

What's the reason for building server module alone ?

Cheers

On Thu, Mar 7, 2013 at 6:36 PM, Shivendra Singh <
shivendra.p.singh@oracle.com> wrote:

> Hi,
>
> I am trying to test and pacakge just the Hbase-server for the branch-0.95
> and I am getting following error in PS.
> Please let me know what I am missing here.
> If I use the option -am (also make) it succeeds fine, does it mean that I
> cannot build hbase-server alone?
>
> Thanks,
> Shivendra
>
>
> mvn package -pl hbase-server -amd
> [WARNING]
> [WARNING] Some problems were encountered while building the effective
> settings
> [WARNING] Expected root element 'settings' but found 'proxies' (position:
> START_TAG seen <proxies>... @1:9)  @ /home/shivends/.m2/settings.**xml,
> line 1, column 9
> [WARNING]
> [INFO] Scanning for projects...
> [INFO] ------------------------------**------------------------------**
> ------------
> [INFO] Reactor Build Order:
> [INFO]
> [INFO] HBase - Server
> [INFO] HBase - Integration Tests
> [INFO] HBase - Examples
> [INFO]
> [INFO] ------------------------------**------------------------------**
> ------------
> [INFO] Building HBase - Server 0.95-SNAPSHOT
> [INFO] ------------------------------**------------------------------**
> ------------
> [INFO] ------------------------------**------------------------------**
> ------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] HBase - Server ..............................**...... FAILURE
> [4.452s]
> [INFO] HBase - Integration Tests ......................... SKIPPED
> [INFO] HBase - Examples ..............................**.... SKIPPED
> [INFO] ------------------------------**------------------------------**
> ------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------**------------------------------**
> ------------
> [INFO] Total time: 5.194s
> [INFO] Finished at: Thu Mar 07 18:16:40 PST 2013
> [INFO] Final Memory: 10M/149M
> [INFO] ------------------------------**------------------------------**
> ------------
> [ERROR] Failed to execute goal on project hbase-server: Could not resolve
> dependencies for project org.apache.hbase:hbase-server:**jar:0.95-SNAPSHOT:
> The following artifacts could not be resolved:
> org.apache.hbase:hbase-common:**jar:0.95-SNAPSHOT, org.apache.hbase:hbase-
> **protocol:jar:0.95-SNAPSHOT, org.apache.hbase:hbase-client:**jar:0.95-SNAPSHOT,
> org.apache.hbase:hbase-prefix-**tree:jar:0.95-SNAPSHOT,
> org.apache.hbase:hbase-common:**jar:tests:0.95-SNAPSHOT,
> org.apache.hbase:hbase-hadoop-**compat:jar:0.95-SNAPSHOT,
> org.apache.hbase:hbase-hadoop-**compat:jar:tests:0.95-**SNAPSHOT,
> org.apache.hbase:hbase-**hadoop1-compat:jar:0.95-**SNAPSHOT,
> org.apache.hbase:hbase-**hadoop1-compat:jar:tests:0.95-**SNAPSHOT:
> Failure to find org.apache.hbase:hbase-common:**jar:0.95-SNAPSHOT in
> http://repository-netty.forge.**cloudbees.com/snapshot/<http://repository-netty.forge.cloudbees.com/snapshot/>was
cached in the local repository, resolution will not be reattempted
> until the update interval of cloudbees netty has elapsed or updates are
> force.
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message