hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: Change HBase version string from 0.95.0-SNAPSHOT to 0.95.0-hadoop1-SNAPSHOT and 0.95.0-hadoop2-SNAPSHOT?
Date Fri, 29 Mar 2013 23:50:31 GMT
On Fri, Mar 29, 2013 at 3:59 PM, Enis Söztutar <enis.soz@gmail.com> wrote:

> I remember to trying the classifiers approach, and cannot getting it to
> work, but I don't remember the specifics. If we can get it working, than I
> would vote for the specifiers option as long as it also works with test
> jars, and maven deploy.
> I think it was in this issue:
> https://issues.apache.org/jira/browse/HBASE-6929
> I can't see the classifier in the published pom:
> http://repo1.maven.org/maven2/org/apache/avro/avro/1.7.3/avro-1.7.3.pom

Thanks Enis for pointer where we banged our heads against this before.

@Wing Yew  I tried using classifiers.  It was actually simple to put in
place since all modules inherited jar config from parent.  All is well till
we hit the assembly at the end of the build.  The moduleSet in assembly
spec. is blind to classifiers so I get errors like this:

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-assembly-plugin:2.4:single (default-cli) on
project hbase-assembly: Failed to create assembly: Error adding file
'org.apache.hbase:hbase-common:jar:0.97.0-SNAPSHOT' to archive:
/Users/stack/checkouts/hbase/hbase-common/target/classes isn't a file. ->
[Help 1]

i.e. it can't see the jar that has classifier added so it fails to copy it
and its dependencies.

I poked around and there is nothing in moduleSet that lets you specify a

I messed w/ dependencySets and includes trying to wildcard hbase artifacts
and I get same error above.

(avro doesn't use assembly plugin going by its pom and its build.sh).

Thanks for the pointer,

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message