hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arup Malakar (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-7762) HBase version mismatch between package-info and hbase-defaults.xml
Date Fri, 08 Feb 2013 01:04:12 GMT

     [ https://issues.apache.org/jira/browse/HBASE-7762?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arup Malakar resolved HBASE-7762.
---------------------------------

    Resolution: Invalid

Hi Anoop, on running the same test again the error seemed to have gone away. Looking at the
code also it clearly indicated that I must have had another hbase-site.xml/hbase-default.xml
with version being 0.94.2. I can not seem to reproduce this anymore. I will mark this JIRA
invalid.

Thanks!
                
> HBase version mismatch between package-info and hbase-defaults.xml
> ------------------------------------------------------------------
>
>                 Key: HBASE-7762
>                 URL: https://issues.apache.org/jira/browse/HBASE-7762
>             Project: HBase
>          Issue Type: Bug
>         Environment: hbase-0.95.5
> hadoop-0.23.3.1
> hive-0.10
> hcatalog-0.5
>            Reporter: Arup Malakar
>
> When hbase is used to store external table in conjunction with hive, the create table
in hive fails with the following error:
> {code}
> Failed with exception java.lang.RuntimeException: hbase-default.xml file seems to be
for and old version of HBase (0.94.2), this version is 0.9
> 4.5.5.1302010003
> {code}
> Looking at the classpath I don't see multiple version of hbase jar. Not sure where the
0.94.2 is coming from. It works fine if _hbase.defaults.for.version.skip_ is set to _true_.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message