hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Hsieh <...@cloudera.com>
Subject Re: [poll] Does anyone run or test against hadoop 0.21, 0.22, 0.23 under HBase 0.92.0+/0.94.0?
Date Thu, 19 Jul 2012 00:23:13 GMT

On Wed, Jul 18, 2012 at 5:09 PM, Stack <stack@duboce.net> wrote:

> On Wed, Jul 18, 2012 at 9:58 PM, Jonathan Hsieh <jon@cloudera.com> wrote:
> > Hi,
> >
> > I'm trying to get a feel to see how affected folks would be if we
> > potentially only had hbase support a hadoop 1.0 build and a hadoop 2.0
> > build profile (and perhaps a hadoop 3.0-SNAPSHOT proflile).
>  Specifically,
> > does anyone use hbase on top of hadoop 0.21.x, 0.22.x, or 0.23.x (which
> > became hadoop 2.0.x recently)
> >
> Jon, what versions of HBase are you asking about?  A while back we
> said that HBase 0.96.0 would be the first release that could assume
> for a minimum a 1.0.x API [1].  Previous releases we postulated
> (though probably haven't tested much) could be run on versions as old
> as branch-0.20-append.  We might want to reexamine this "decision" if
> we we are talking HBase 0.94 (or even HBase 0.92)?
> Its in the the title -- I was asking about specifically about hbase
0.92.0+/0.94.0+.  I should have also included 0.20-append in the list of

I don't think this affects the decision you refer to. I'm not trying to age
off older versions -- I'm trying find out from this discussion which
"newer" versions we should have HBase work/compile against, and if we can
just say 1.x and 2.x and not include the 0.21, 0.22, and now 0.23 branches.

We've found out along the way that while different Hadoop versions are
"source-compatible" (no source change but requires recompile), they are not
"binary-compatible" (one hbase jar for all hadoop versions).

As examples, an hbase compiled against a hadoop 1.0 hdfs doesn't work ontop
of a hadoop 2.0 hdfs, and that a hbase compiled against hadoop 2.0 hdfs
doesn't work on a hadoop 1.0 cluster.  To add to the mix, today we learned
that an hbase compiled against a hadoop 23 doesn't work on a hadoop 2.0
hdfs cluster.

> +1 on hadoop 1.0 and 2.0 versions/APIs only.  I'd be fine w/ a 3.0
> snapshot.
> Any more versions than this and we'll be spending all dev effort on a
> shim layer that looks like the Pompidou Center to make the various
> HBase versions run (slowly) over all 57 varieties of Hadoop.
> St.Ack
> 1.
> http://search-hadoop.com/m/5qFYe24EsUb2/hbase+0.96+hadoop+1.0&subj=Re+DISCUSS+Have+hbase+require+at+least+hadoop+1+0+0+in+hbase+0+96+0+

// Jonathan Hsieh (shay)
// Software Engineer, Cloudera
// jon@cloudera.com

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message