hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roman Shaposhnik <...@apache.org>
Subject Re: HBASE-5955
Date Sun, 01 Jul 2012 02:17:59 GMT
On Sat, Jun 30, 2012 at 5:24 PM, lars hofhansl <lhofhansl@yahoo.com> wrote:
> So will Guava 11.0.2 in hbase 0.94 be a problem? Should we not update Guava (at least
not until 0.96)?

In general, I don't think there's good answer to how dependencies
are supposed to be managed wrt. version numbers. After all, all
of the Hadoop ecosystem projects have to deal with the fact that
there's at least half a dozen different branches of Hadoop they have
to work with. It is virtually guaranteed that whatever you do you will
end up incompatible with one of those builds and most likely the
version of a dependency that wins will be the one that Hadoop is using.

IOW, whatever is specified in the POM file of individual projects is
likely to be overridden anyway and the best the could be done
is to avoid known gaping incompatibility holes (of which I'm not
aware of too many).

Thanks,
Roman.

Mime
View raw message