hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Hsieh <...@cloudera.com>
Subject Re: Publishing jars for hbase compiled against hadoop 0.23.x/hadoop 2.0.x
Date Wed, 16 May 2012 18:35:37 GMT
Andy,

Ah, ok that sounds reasonable.  Some this would be similar to how the
security build used to have a "-security" suffix but for hadoop2 we'd have
something like a "-hadoop2" suffix instead.

Jon.

On Wed, May 16, 2012 at 11:27 AM, Andrew Purtell <apurtell@apache.org>wrote:

> On Wed, May 16, 2012 at 11:24 AM, Jonathan Hsieh <jon@cloudera.com> wrote:
> > I've gotten pinged by folks working on Apache Flume, a project that
> depends
> > directly upon hbase and hadoop hdfs jars about how to get the proper
> hbase
> > jars that work against hadoop 1.0 and hadoop 0.23/2.0.
> > Unfortunately, the transition from hadoop 1.0.0 to hadoop 0.23.x/2.0
> > requires hbase to be recompiled to run against the different hadoop
> > version. ("compile compatible" but not "binary compatible").
> >
> > Currently, we build and publish hbase jars compiled against hadoop 1.0.x.
> >
> > What is the right way to publish poms/jars for those who want use an
> hbase
> > jars compiled against hadoop 0.23/2.0?  Is there a right way?
>
> This requires we add a version suffix for the Hadoop version used during
> build?
>
> Best regards,
>
>    - Andy
>
> Problems worthy of attack prove their worth by hitting back. - Piet
> Hein (via Tom White)
>



-- 
// Jonathan Hsieh (shay)
// Software Engineer, Cloudera
// jon@cloudera.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message